XAMPP no longer opens pages in "localhost" after upgrading to Big Sur

Keywords: General - OS X - Technical issue - Other
Description:
After upgrading to Mac OS Big Sur, my web pages cannot be viewed locally on browsers. Every attempt to view them locally (by right-clicking the file in the latest Dreamweaver version) opens the page in browsers with this error message: "Cannot connect to the server “localhost.”

Updated XAMPP versions have worked successfully for ±six years. Now, in Big Sur, browsers cannot connect to “localhost.”

Is there yet an upgrade-fix for this?

Hello, Jota: Is there an ETA on when XAMPP will create an upgraded version that allows me/us to again reliably view our pages locally using “localhost”?

For the past two weeks, after upgrading to Mac OS Big Sur, every attempt to view my pages locally using “localhost” brings up this error message (on Safari and Chrome): "Cannot connect to the server “localhost.” Thank you, Jota, in advance.

Hi @wcamp,

Did you use the OS X VM or the native installer to install XAMPP in your Mac? We need this info to provide you with the correct commands to debug this issue.

Apart from that, did you check if the XAMPP services (Apache, MariaDB) are started when you access your site using the web browser?

Thanks

Thank you, Jota, for your prompt e-reply!

Answering your first question, I cannot remember which version I installed weeks ago. Is there an identifying factor that will enable me to know the file type? I’ll upload three screenshots with the hope that they’ll reveal the answer you seek.

  1. ![Screen Shot 2021-05-07 at 12.00.25 PM|670x500] [The community.bitnami page prevents me from submitting more than one screenshot. Darn. I’ve removed this screenshot.]

  2. ![Screen Shot 2021-05-07 at 12.01.18 PM|690x491][I deleted this screenshot . . .]

Regarding your second question, I don’t know what you’re specifically asking. In this next screenshot, you can see what I get a few seconds after I start and manage XAMPP.
![Screen Shot 2021-05-07 at 12.01.01 PM|690x490] [I had to also delete this screenshot.]

And here’s what I see after attempting to open a file from Dreamweaver’s “Open in browser” feature to shows the page locally on browsers (Safari and Chrome).
![Screen Shot 2021-05-07 at 12.16.18 PM|690x231] [Sadly, I had to also delete this screenshot.]

I hope that this post (without my screenshots) is helpful, Jota. I’m not well-versed in troubleshooting coding and the Internet. Please accept my unfamiliarity with this going forward in your e-replies. Thanks, in advance, for your support.

Hi @wcamp,

The screenshot got broken but I could see you were using the XAMPP native installer. I just edited your trust level in this community forum so you can now post all the other images in the thread. Could you please upload them so we can take a look at the error you get when starting the services?

Apart from the screenshots, can you also share the content (or the last lines) of the Apache’s error_log file (/Applications/XAMPP/logs/error_log)?

image

Thanks

Glad to find your advisory that I did download and install the native version of XAMPP, not the VM version.

Thank you for enabling me to attach additional screenshots, which might show the cause(s) of the problem).

  1. The first screenshot shows your latest request for the error_log file. I suspect that there is not file to be found on my iMac (running OS 11.3, Big Sur).

Not first that the error log appears to be empty. If so, does that fact help you appreciate the cause of my failure to get XAMPP to open :localhost" on my browsers?

Please also note that there are numerous “authdigest_shm.####” files between my “access_log” and my “error_log” files, yet there are no such entries in your screenshot. Does that help you figure our the cause of the problem?

  1. This second screenshot shows what opens when I start XAMPP.

  1. When I select the “Manage Servers” tab, this is what opens. After two seconds, the “Running” status for Apache Web Server turns to “Stopped.”

  1. When I looked in the Applications folder to see what shows for “XAMPP,” this next screenshot shows that the file size is 460.4 MB but the version shows as “1.0.3” despite the fact that I downloaded version “7.4.18-0.”

  1. Finally, this screenshot documents what appears when I right-click Dreamweaver’s selected file and choose “Open in browser.”

None of my files within my domain open in “localhost” on Safari and Chrome. :cry:

I hope very much that what I’ve described and presented will enable you to learn what I must do to get XAMPP to again be reliably operational.

Thanks, in advance, jota.

Warren

Hi @wcamp,

What happens when you click on “Start All” in the XAMPP manager tool? Is there any new message in the “Server Events” tab?

Hello, again, jota:

At your suggestion, I opened XAMPP, then clicked “Start All.” Within6 seconds, I saw the “Stopped” text appear for Apache Web Server, as shown in the third screenshot in yesterday’s post.

I then opened “Server Events” and found this:

I hope that what it shows indicates the problem’s cause. Yes?

Warren

Hi @wcamp,

Let’s try to obtain more info. Can you run these commands in the command line?

cd /Applications/XAMPP
sudo ./bin/apachectl -t
sudo ./bin/apachectl -X

Thanks

Thanks for your suggestion, jota. Unfortunately, I have no idea what to do. Please describe (in lay terms) what I’m to do and how/where I’m to do it.

Much appreciated.

Hi @wcamp,

You need to open the terminal of your Mac OS X and copy, paste and run the commands I posted above.

Thanks very much, jota, for clarifying what you suggested I do. I’ve done it and received this response that I hope helps you put your finger on the cause(s) of my problem.

Please tell me what you learn from Terminal’s [two-part] response and what you suggest I do next to get XAMPP back into operation.

Many thanks in advance, jota.

Warren

Hi @wcamp,

It seems libiconv is not installed in your Mac OS X machine. Can you install it and run the apachectl command again?

brew install libiconv
cd /Applications/XAMPP
sudo ./bin/apachectl -t

If it doesn’t return any errors, you should be able to start Apache again.

Thanks, pal. I followed your latest direction and attempted to install “libiconv” using Terminal. It apparently wasn’t successful, as shown in this first screenshot.

I then tried restarting XAMPP but got this error message after three seconds.

I hope this latest effort proves helpful in your diagnosis of the problem.

Sincerely,

Warren

Hi @wcamp,

It seems you do not have brew in the machine, can you install it?

https://brew.sh/

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

Once brew is installed, please run again the commands I posted in my previous command.

Hi, jota:

I did as you asked: after adding your latest command into Terminal, I added your first requested command (./bin/apachectl…) then your second command (brew install libiconv).

Here’s what Terminal brought up . . .

I then opened “manager-osx” and restarted the three options. After five seconds, Apache Web Server changes from “Running” to “Stopped.” None of my pages or files (whether .jpg, .html, .php, etc) open from Dreamweaver as they had three weeks ago before upgrading to Big Sur.

Might there be something else to pursue and correct?

Wondering Warren

Hi @wcamp,

You continue getting the “brew: command not found” error in the terminal and that means that brew was not installed correctly. Can you run the command to install brew in your machine and post here its output?

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

Jota. Following your latest suggestion, I again attempted to load “brew.” I believe that “brew” has now been successfully installed. Please see my screenshot of Terminal’s activity.

After getting that result, I opened “manager-osx” and restarted XAMPP (with my fingers crossed). Five seconds later, Apache Web Server [again] turned to “Stopped.” I tried opening an HTML page from Dreamweaver but “localhost” still wasn’t able to open in any browser. Sorry.

Do you have a next step for me to take, hopefully?

Thanks, pal.

Warren

Hi @wcamp,

The command line asked you to press return (or enter) to continue with the process and install brew. The screenshot you posted doesn’t confirm that you installed it. What did you do?

Once you install brew, you need to install libiconv using brew and then start the OS X VM.

Note: if you are not familiar with the OS X command line, please find someone in your community who helps you install brew and libiconv using the commands I posted above

Please forgive me, jota. I neglected to see that line at the bottom of the Terminal screen.

I believe that I’ve now installed “brew.” I’ll attach screenshots of two portions of the long Terminal window. Hopefully you’ll know if what I’d done was complete and successful.

. . . followed by . . .

I’ll now open XAMPP by activating “manager-osx”. I hope very much that Apache Web Server will not turn to “Stopped” but with reveal a “Running” result after I restart “manager-osx.”

. . .

Darn. This time, the “Stopped” notification appeared quickly: within three seconds.

I’ve now opened the “brew.sh” Home page but I can’t intuitively tell if I’m to do something more to install “brew.”

Is there a “next step” I need to take to activate “brew” so that Apache Web Server will again run as it has for me?

I appreciate your continued support, jota, very much.

Warren