Xampp-bitnami-wordpress "Error establishing a database connection"

So I had XAMPP installed on my Macbook pro and installed the bitnami wordpress package for XAMPP. It worked well for a bit but I was busy to do much development. 3 weeks later (yesterday) I had issues with mysql Server starting up on XAMPP. I solved it and opened up the wordpress site. It appeared fine until I decided to log in and was faced with the login loop where it brings me right back to the login screen.

To solve that I uninstalled the wordpress installation using the bitnami uninstall file. I verified that the username and table were no longer in the database and tried reinstalling… Now I’m stuck with the dreaded “Error establishing a database connection”. Any Ideas?

using bitnami-wordpress-4.8-0-module-osx-x86_64-installer for XAMPP.

Hi,

Could you check the Apache error log? What errors do you see? There we can see what is causing the database connection issue.

Hope it helps.

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

Hello,
I am having an issue with XAMPP. When I download XAMPP it is giving me an error message stating that because of an activated user control on my system functions of XAMPP are possibly restricted. I tried deactivating the UAC but I am not sure how to do that exactly. When I pull up the XAMPP control panel. it is giving me messages that I am running the application with administrator rights and that the install directory contains spaces. The control panel won’t let me update the apache 2.4 settings and is giving me the message “error: cannot create file. access is denied”. I am not sure how to fix this. I have tried uninstalling and reinstalling the application but the same problem occures.

Hi @msnyder115,

I found the following steps to disable UAC:

To disable the UAC, use the program “msconfig”. In “msconfig” go to “Tools”, select “disable user account control” and verify your selection. Now you must restart Windows. At the same time, you can enable the UAC again.

Can you try that?

Regards,
Michiel