Www.domain.com to domain.com redirection

Keywords: Liferay - Google Cloud Platform - Technical issue - Other
bnsupport ID: e31de19d-cbe8-a6d3-7d8e-f69cee1006a7
Description:
Hi, good afternoon.
I can’t configure my Liferay instance to fix this redirection.
I’ve followed all steps included here: https://docs.bitnami.com/general/apps/liferay/administration/redirect-custom-domains/#redirect-www-myapp-example-com-to-myapp-example-com

I think the problem is that I’m not using Bitnami SSL cert: I don’t need it.
Culd you please guide me on this process?

Thank you.

Hi @johndove,

It seems you added the information to the httpd-vhosts.conf file but you didn’t include that file into the Apache’s configuration. If you want to redirect your requests to always use domain.com, you can follow this guide to achieve that.

https://docs.bitnami.com/general/apps/liferay/administration/use-single-domain/#approach-b-self-contained-bitnami-installations

Happy to help!


Was my answer helpful? Click on :heart:

Hi @jota,
I’ve followed this information (https://youtu.be/BF4OlDwPZds?list=PLGgVZHi3XQNm-dQwUU0K83kMKIdCILGy7) and now it works.
One question. Is there a document or an article or something like that to configure a bitnami instalation using Cloudflare?
Thank you

Hi @johndove,

The only documentation we have regarding CloudFlare is this one

https://docs.bitnami.com/aws/faq/administration/enable-ssl-cloudflare/

It explains how to configure the SSL certificate there. You will need to review the configuration to redirect the requests in your server because if you connect cloudflare and your server now, it’ll get redirected as well.

Let us know if you have any questions.

Hi @jota,
Thank you. Previously I was using Cloudflare but its configuration was making problems with SSL and redirections at bitmani.
I will test it again and I’ll let you know the results.
Thank you very much for your support.
Have a nice day.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.