Wp core update > permission error

Keywords: WordPress - AWS - Technical issue - Permissions

bndiagnostic ID: 436a5972-d3aa-ea73-91f7-d0e07d127edf

bndiagnostic output:

? Apache: Found possible issues
? Mariadb: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mariadb/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:

Warning: chmod(): Operation not permitted in /opt/bitnami/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 173

1 Like

I have run

sudo chown -R bitnami:daemon /opt/bitnami/wordpress;
sudo find /opt/bitnami/wordpress/ -type d -exec chmod 775 {} ;
sudo find /opt/bitnami/wordpress/ -type f -exec chmod 664 {} ;
sudo chown 640 /opt/bitnami/wordpress/wp-config.php;

and still getting the same warning message when upgrading

Hi @futureyoon ,

Please take a look at this other post to reset the permissions configuration

As mentioned earlier, I ran those commands already and that didnt fix the issue. That’s why I submitted the ticket here.

I have turned off all plugins as well

The commands I shared above are different from the ones you posted. Please run all the commands to ensure you have the correct permissions configuration. If WordPress needs to write the wp-config.php file, you can modify its permissions by using this command

sudo chmod 660 /opt/bitnami/wordpress/wp-config.php

I have run the command you share
sudo chmod 660 /opt/bitnami/wordpress/wp-config.php

the error is still happening when upgrading the wp core

I’ve got the same issue after run core update as well.

If you reset the permissions configuration and you are still getting an error when updating the app, then I suggest you contact WordPress to obtain more information about how to debug this issue

https://wordpress.org/support/

Hmm… @jota, I have installed a brand new instance in AWS with bitnami wordpress marketplace and then run all the permission commands recommended although that’s the default settings (but still ran them).

Yet I am getting the same warning message.
sudo wp core update --version=5.9.3 --force

and then the other way around

sudo wp core update

and I talked to wordpress support, they dont deal with permission issue.

so what is your next recommendation?

One another question: is this warning message can just be ignored?

plz help.

Thank you
Rohan

Hi @futureyoon ,

I just reproduced the issue and got more information. The wp tool uses daemon as user to run the different commands to update WordPress. It seems WordPress tries to change the ownership configuration of some files and that’s why the tool shows those warnings, but you shouldn’t worry about them, the application is updated properly. If you do not want to receive those warnings when running the wp tool, please run this command

sudo chown -R daemon:daemon /opt/bitnami/wordpress/ /bitnami/wordpress/

If you want to reset the permissions after updating the application, please take a look at this other post