WP Contents permissions need to be changed

Type: Bitnami Support Tool

Description:
Hi, I have been trying to change wp-content folder permission to 775 but my efforts to do so have proved abortive. I’ve tried several methods, (running chmod in command line, and changed file permissions using fileZilla), none works. In file zilla, i got this message:
“set attrs for /opt/bitnami/apps/wordpress/htdocs/wp-content/languages/pt_BR-1bba9045bb07c89671c88a3f328548e8.json: permission denied Status”

Apparently, Bitnami has to change the permissions. I can’t do that. Please help guys.

Please run the commands in this post to reset the permissions configuration

Happy to help!


Was my answer helpful? Click on :heart:

Hi Jota, Thank you for responding. I ran the commands you sent, it didn’t work. I ran as per the file path in attached doc title “bitnami” (file path to wp-content: **/opt/bitnami/apps/wordpress/htdocs/wp-content/).

The second document title “doc1” shows wp-content permission is still 755. What am i doing wrong?

!

Here’s the second document in attached file.

Hi @kenny,

Sorry for the wrong commands, you are using the old directory structure and that’s why the commands didn’t work. Please run these other commands

sudo chown -R bitnami:daemon /opt/bitnami/apps/wordpress/htdocs
sudo find /opt/bitnami/apps/wordpress/htdocs -type d -exec chmod 775 {} \;
sudo find /opt/bitnami/apps/wordpress/htdocs -type f -exec chmod 664 {} \;
sudo chmod 640 /opt/bitnami/apps/wordpress/htdocs/wp-config.php