WP CMS Nginx SSL refuses to respond with memory errors

Keywords: WordPress + NGINX + SSL - Google Cloud Platform - Technical issue - Other

bndiagnostic ID: 97fe3fd7-423a-b902-faa0-602df1c4665a

bndiagnostic output:

? Wordpress: Found possible issues
? Nginx: Found possible issues
? Php: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/administration/understand-file-permissions/
https://docs.bitnami.com/installer/infrastructure/nginx/troubleshooting/
https://docs.bitnami.com/general/apps/akeneo/administration/increase-memory-limit/

bndiagnostic failure reason: The documentation did not make any significant change

Description:
My WP CMS instance WordPress with NGINX and SSL Certified by Bitnami and Automattic Google Cloud Platform Runs on: Google Compute Engine

  •   Type: Virtual machines, Single VM
    
  •   Last updated: 4/11/22
    
  •   Category: Blog & CMS
    
  •   Version: 5.9.2-17-r03
    
  •   Operating System: Debian 10
    
  •   Package contents: Akismet 4.2.2 , All-in-One WP Migration 7.57.0 , Simple Tags 2.5.7 , AMP 2.2.1 , WordPress Mail SMTP 2.9.0 , All in One SEO Pack 4.1.9-4 , Google Analytics Dashboard 7.18.0 , W3 Total Cache 2.2.1-0 , Jetpack 9.9.1-0 , WordPress Amazon Polly Plugin 4.3.2 , WordPress 5.9.2 , MariaDB 10.3.34 , mod_pagespeed library 1.13.35-2 , mod_pagespeed_ap24 library 1.13.35-2 , ModSecurity Apache Connector 0.20210819.0 , Apache utilities (APR) 1.6.1 , Apache Portable Runtime (APR) 1.7.0 , ModSecurity 3.0.6 , ModSecurity2 2.9.5 , Apache 2.4.53 , Apache PageSpeed Module 1.13.35-2 , qpress 11.0.0-0 , Percona XtraBackup 8.0.27-19 , phpMyAdmin 5.1.3 , Bndiagnostic Tool 0.9.17 , vmod-querystring 2.0.3 , Varnish 6.6.2 , Gonit 0.2.5 , wait-for-port 1.0.1 , MySQL 8.0.28 , nss_wrapper 1.1.11 , Git 2.35.1 , gosu 1.14.0 , Composer 2.2.10 , PECL APC User Cache 5.1.21 , PECL PHP driver for Mcrypt 1.0.4 , MaxMind DB Reader PHP API 1.11.0 , libmemcached 3.2.0 , PECL PHP driver for Xdebug 3.1.3 , libmaxminddb 1.6.0 , PECL PHP driver for Imagick 3.7.0 , PECL PHP driver for MongoDB 1.13.0 , IMAP 2007.0.0 , PHP 7.4.28 , WP-CLI 2.6.0 , Bncert Tool 0.7.3 , Brotli 1.0.9 , ini-file 1.4.1 , Nginx GeoIP2 module 3.3.0 , Nginx substitutions filter 0.20220124.0 , Nginx traffic status module 0.1.18 , Nginx 1.21.6 , Nginx Brotli module 0.20201006.0 , render-template 1.0.1
    
  •   Add to Service Catalog: Deployment .zip file   
    

ISSUE:
Periodically, the whole server becomes completely unresponsive. The only solution is to restart the Server as it down not even respond to SSH.

Requesting assistance on how to resolve.

WPCMS Nginx and Maria DB
The WP CMS theme that I am using is Uncode. The them requires the following server requirements which I are configured. https://support.undsgn.com/hc/en-us/articles/213453949

sudo tail -n 20 /opt/bitnami/wordpress/wp-content/debug.log
[12-Apr-2022 03:58:17 UTC] PHP Notice: Undefined property: stdClass::$plugin in /opt/bitnami/wordpress/wp-includes/class-wp-list-util.php on line 167
[12-Apr-2022 03:58:17 UTC] PHP Notice: Undefined property: stdClass::$plugin in /opt/bitnami/wordpress/wp-includes/class-wp-list-util.php on line 167
[12-Apr-2022 03:12:07 UTC] PHP Warning: Cannot modify header information - headers already sent in /bitnami/wordpress/wp-content/plugins/uncode-privacy/includes/class-uncode-toolkit-privacy-public.php on line 342
[1
[12-Apr-2022 00:15:14 UTC] PHP Fatal error: Out of memory (allocated 2097152) (tried to allocate 2377008 bytes) in /opt/bitnami/wordpress/wp-includes/wp-db.php on line 2162
[12-Apr-2022 00:15:14 UTC] PHP Fatal error: Out of memory (allocated 2097152) (tried to allocate 2377008 bytes) in /opt/bitnami/wordpress/wp-includes/wp-db.php on line 2162
[12-Apr-2022 00:16:25 UTC] PHP Warning: Cannot modify header information - headers already sent in /bitnami/wordpress/wp-content/plugins/uncode-privacy/includes/class-uncode-toolkit-privacy-public.php on line 342
[12-Apr-2022 00:16:25 UTC] PHP Warning: Cannot modify header information - headers already sent in /bitnami/wordpress/wp-content/plugins/uncode-privacy/includes/class-uncode-toolkit-privacy-public.php on line 342
[12-Apr-2022 00:16:44 UTC] PHP Warning: Cannot modify header information - headers already sent in /bitnami/wordpress/wp-content/plugins/uncode-privacy/includes/class-uncode-toolkit-privacy-public.php on line 342
[12-Apr-2022

wp-config.php define( ‘WP_MEMORY_LIMIT’, ‘512M’ ); define( ‘WP_DEBUG’, true );
// Enable Debug logging to the /wp-content/debug.log file
define( ‘WP_DEBUG_LOG’, true );
// Disable display of errors and warnings
define( ‘WP_DEBUG_DISPLAY’, false ); Fix: WordPress Memory Exhausted Error – Increase PHP Memory Fix: WordPress Memory Exhausted Error - Increase PHP Memory
Changes to php.ini nano /opt/bitnami/php/etc/php.ini memory_limit 512M max_input_vars 3000 max_execution_time 120 post_max_size 80M upload_max_filesize 124M allow_url_fopen ON asp_tags OFF — Not available in php.ini
I have added debugging and logging of error messages and the shows memory errors Restarted instance sudo /opt/bitnami/ctlscript.sh restart

Reviewed Modify The Memory Limit Modify the memory limit Memory limit is at 512 in all cases

/opt/bitnami/php/etc/memory.conf . Memory.conf is s below. If you recommend a change, I will need to know the exact values too change pm.max_children=60
pm.start_servers=40
pm.min_spare_servers=40
pm.max_spare_servers=45 pm.max_requests=5000 How can I address the errors below

[11-Apr-2022 22:32:11] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 8 children, there are 39 idle, and 53 total children
[11-Apr-2022 22:32:12] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 16 children, there are 39 idle, and 54 total children
[11-Apr-2022 22:32:13] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 55 total children
[11-Apr-2022 22:32:14] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 56 total children
[11-Apr-2022 22:32:15] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 57 total children
[11-Apr-2022 22:32:18] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 58 total children
[11-Apr-2022 22:32:21] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 59 total children
[11-Apr-2022 22:32:24] WARNING: [pool www] server reached pm.max_children setting (60), consider raising it
[11-Apr-2022 23:16:02] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 8 children, there are 39 idle, and 48 total children
[11-Apr-2022 23:16:03] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 16 children, there are 39 idle, and 49 total children
[11-Apr-2022 23:16:04] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 50 total children
[12-Apr-2022 00:14:35] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 8 children, there are 39 idle, and 48 total children
[12-Apr-2022 00:21:50] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 8 children, there are 39 idle, and 53 total children
[12-Apr-2022 00:21:51] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 16 children, there are 39 idle, and 54 total children
[12-Apr-2022 00:21:52] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 55 total children
[12-Apr-2022 00:21:53] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 56 total children
[12-Apr-2022 00:21:55] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 57 total children
[12-Apr-2022 00:21:56] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 58 total children
[12-Apr-2022 00:21:57] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 32 children, there are 39 idle, and 59 total children
[12-Apr-2022 00:21:58] WARNING: [pool www] server reached pm.max_children setting (60), consider raising it

Links reviewed without solution
Modifying PHP php_max_vars - #4 by gongomgra Modifying PHP php_max_vars

This error is similar to that on this thread but slightly different stacks of course

Hi @codepantry,

I recommend upgrading the instance:

https://docs.bitnami.com/aws/faq/administration/upgrade-ami/

Best regards,
Michiel

@michiel I am in GCP and not AWS per my posting above. I installed this instance on March 28th, 2022. Is there an upgrade for GCP and if so, what issue does it address? Thank you.

I am having issue with my bitnami Ngnix + SSL instance here is my code

740f1223-860f-4b47-d7a2-9d36d4e7f821

Hi @codepantry,

My apologies. The following guide shows how you can upgrade your GCE instance to increase the available RAM.

https://docs.bitnami.com/google/faq/administration/change-server-type/

Regards,
Michiel

Hi @hzia786,

Please create a separate post for your issue.

Regards,
Michiel