wordpressApache service installation error due to syntax error in conf file

Keywords: WordPress - Installers - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: 7515b013-42a9-c4ad-fe10-983df7dd9008

Description:
Running a clean install of the windows wordpress installer from https://bitnami.com/stack/wordpress/installer gives a ‘Unable to install Apache as a service with name wordpressApache’ error which appears to be caused by a typo in the /apache2/conf/httpd.conf file calling /imagemagick/bin/CORE_RL_Magick++_.dll which throws a module not found error.

Script stderr:
Installing the ‘wordpressApache’ service
The ‘wordpressApache’ service is successfully installed.
Testing httpd.conf…
Errors reported here must be corrected before the service can be started.
httpd.exe: Syntax error on line 576 of D:/Website/apache2/conf/httpd.conf: Cannot load D:\Website\imagemagick\bin\CORE_RL_Magick++_.dll into server: The specified module could not be found.

Unable to install Apache as a service with name wordpressApache
[13:59:09] [logrotate:installation-aborted] Running action list…
[13:59:09] [apache:installation-aborted] Running action list…
Executing sc stop wordpressApache
Script exit code: 1062

Script output:
[SC] ControlService FAILED 1062:

The service has not been started.

Any help in getting the wordpressApache service running properly would be greatly appreciated.

Hi @SKaret,

Sorry for the inconvenience. We have not received any ticket with this error and the solution passed our tests. However, we are going to try to reproduce the error and will update this thread as soon as we have more information. Could you please let us know the Windows’ version you have so we can try to reproduce the environment as well?

Thanks

Edition Windows 10 Home
Version 21H1
Installed on ‎10/‎12/‎2020
OS build 19043.1288
Experience Windows Feature Experience Pack 120.2212.3920.0

Hi @SKaret,

Thanks for the info. We will work on reproducing this and will update the ticket as soon as we have more information.

Hi @SKaret,

I just tried to reproduce the issue in a fresh machine of Windows Server 2019 (same than Windows 10) and couldn’t do so. The Apache’s service gets installed properly and it doesn’t return any error.

Installing Apache as a Windows service with name wordpressApache
Executing C:\Bitnami\wordpress-5.8.1-2/apache2\bin\httpd.exe -k install -n "wordpressApache" -f "C:\Bitnami\WORDPR~1.1-2\apache2\conf\httpd.conf"
Script exit code: 0

Script output:
 

Script stderr:
 Installing the 'wordpressApache' service
The 'wordpressApache' service is successfully installed.
Testing httpd.conf....
Errors reported here must be corrected before the service can be started.

Executing cmd /C start /MIN net start wordpressApache
Script exit code: 0

Apart from that, I confirmed that the Imagemagick’s files are there inside the imagemagick folder

  • Could you please check if the dll file is inside the bin folder when the error appears?
  • Could you please check if the machine is running out of RAM memory? Please note that this is one of the reasons why the installation can fail because if it runs out of memory, it will not unpack the files properly.
  • Could you set another drive to install the stack? Is D: an external hard disk?

Thanks

Hi @jota,
I can confirm that the .dll file was in the directory that the path in the httpd file was pointing to. I am also relatively certain it wasn’t a RAM issue as I had 16GB of unused RAM at the time of install. I will attempt to install to my nvme SSD boot drive, though my D: drive is a SATA SSD


The error has happened again when installing to the default location on my C: drive that the installation wizard recommended.
I ran the bndiagnostic tool on this attempt and here’s the ID: e17671dc-f035-38e5-4157-18ef94c72ff9

Hi @SKaret,

What about if you run the install command manually when the error appears? You will need to open the command prompt and run this command

C:\Bitnami\wordpress-5.8.1-2/apache2\bin\httpd.exe -k install -n "wordpressApache" -f "C:\Bitnami\WORDPR~1.1-2\apache2\conf\httpd.conf"

Do you get more information? Is the service installed properly? You can open the services panel and look for the wordpressApache service there.

Thanks

On first running the command I got an error saying the service was already installed, so I deleted the service and restarted the PC, and then re-ran the command and received this error again.

As you can see the “missing” module is located in the path specified.

Edited to change the image to one that actually showed the CORE_RL_Magick++_.dll file

Hi @SKaret,

This is really weird, and we are not able to reproduce the issue. Do you have any antivirus software in your system? Can you disable it and test the installation again?

Thanks