Wordpress website unable to load, error connect() function

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Application configuration

bnsupport ID: 9859b62f-7a4e-103a-5948-d92ea5d28815

bndiagnostic output:

? Nginx: Found possible issues
https://docs.bitnami.com/installer/infrastructure/nginx/troubleshooting/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:

2021/11/06 12:18:11 [error] 10609#0: *114089 connect() to 
unix:/opt/bitnami/php/var/run/www.sock failed (11: Resource temporarily 
unavailable) while connecting to upstream, client: **ip_address**, server: 
localhost, request: "GET /about HTTP/1.1", upstream: 
"fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "ndh.health"
2021/11/06 12:18:11 [error] 10609#0: *114091 connect() to 
Press [Enter] to continue:
unix:/opt/bitnami/php/var/run/www.sock failed (11: Resource temporarily 
unavailable) while connecting to upstream, client: **ip_address**, server: 
localhost, request: "GET /contact-us HTTP/1.1", upstream: 
"fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "ndh.health"
2021/11/06 12:18:11 [error] 10609#0: *114093 connect() to 
unix:/opt/bitnami/php/var/run/www.sock failed (11: Resource temporarily 
unavailable) while connecting to upstream, client: **ip_address**, server: 
localhost, request: "GET /contact HTTP/1.1", upstream: 
"fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "www.ndh.health"

Hi @marissaj.mcdowell,

PHP is reaching the limits and that’s why NGINX can’t connect to the socket

❯ cat php/var/log/php-fpm.log
[01-Nov-2021 15:46:01] WARNING: [pool www] server reached max_children setting (5), consider raising it
[02-Nov-2021 17:44:35] WARNING: [pool www] server reached max_children setting (5), consider raising it
[02-Nov-2021 18:26:12] WARNING: [pool www] server reached max_children setting (5), consider raising it

Please increase the max_children value and restart the PHP-FPM service for the changes to take effect

https://docs.bitnami.com/aws/apps/wordpress-pro/configuration/configure-phpfpm-processes/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.