Wordpress was created without username or password

[IMPORTANT, please fill the questions]

  • Application name and version: bitnami worpress

  • Is it an installer, cloud image or virtual machine?: Installer

  • Operative system/Platform (Linux, Windows, OSX)(x86/x64):Windows 64

  • Was it installed as the root user? yes, as far as I can tell

  • Is there anything you’ve done and/or tried with the application before posting here?
    E.g. changed permissions or installed a plugin:

We assume you are using Bitnami to deploy your application.
Describe here your question/suggestion/issue and how to reproduce it.I tried install worpress and tryd to edit the hellow world page and could not log in


When you installed the stack, it must have prompted you for a
username and a password. Did that screen appear? Have you tried

Best regards,


Hi @jsalmeron,

I just installed bitnami wordpress and have the same problem. it never asked me to set up wordpress username and password, so when I open application (the website), I have no idea how to log in. Would you mind advising how to solve this problem? by the way, my laptop is a mac, and i have installed twice but still same problem.

1 Like

Hi @nhoa6quabhh,

I guess you are using our OS X VM. The default credentials are:



I too am facing the same annoying issue.
Win/Mac/Linux (Mac) OSX VM. 5.9.3-13

No username or password prompted for or provided. davidg suggested username: user password: bitnami - Does not work.

Anyone? Thanks,


Apologies! Eventually found info in docs.

sudo cat /home/bitnami/bitnami_credentials


Hello @edwardcox1 ,
I’m having the same exact issue BUT I cant use the terminal command to find the credentials. The command does not work, it just says there is no such file or directory. Is there any way I can find the credentials without terminal?
Thanks, Peter

As @davidg mentioned, if you are using a OS X VM, the default credentials are user/bitnami

Hi there,

I’m facing the same issue but user:user password:bitnami doesn’t work.

My setup:
Mac OS 12.3.1
Wordpress Stack 5.9.3-18
The installation was successful and I can access the default Wordpress sample page but can’t access the admin page. I was never asked for choosing a username and password during the installation process.
I already used the terminal command sudo cat /home/bitnami/bitnami_credentials but it only gives me this: Password: :key:

What els can I do to find out the credentials?
Thanks in advance.


Hi, I’m running Mac OS 10.15.7 and user/bitnami don’t work for me either. Same exact issue as @Hooperman is describing.

Hi @Hooperman and @meinpeterle1,

Is this the first time you are deploying the Bitnami WordPress OS X VM in your Mac? Please note that if you deployed the app previously, it will use the previous data. You can remove the WordPress installation by checking this guide and you can try later with a fresh deployment


Hi @jota,

thanks for your reply.
Yes, it was the first installation on my Mac.
Now I’ve removed the wp installation as described in the link. These are the steps I’ve done afterwards:

  1. Downloaded new stack “bitnami-wordpress-5.9.3-20-r10-osx-x86_64-vm”
  2. Double Click on dmg-file
  3. Moved Wordpress stack to application folder
  4. Opended Wordpress stack.
  5. I was asked to enter my computer admin credentials for initializing.
  6. Clicked on “Start” on main window.
  7. Clicked on “Go to application”
  8. See the WP demo page
  9. Opened the admin login window http://localhost:8080/wp-login.php

And now I stuck again, because I was never asked to configure a WP admin username and password during the whole process. What do I miss?


You shouldn’t be using localhost but the IP of the VM

Again, the VM is not going to ask you about those credentials because they are already set. If you access the console and run the cat /home/bitnami/bitnami_credentials command, you will get them.


Thanks for your patience. I now used the IP instead. But the console command gave me only “No such file or directory”. It’s a little bit annoying. Any other ideas?


You need to open the VM’s console (by clicking on “Open Terminal”), not the host machine’s console

Great. This was the right hint for me. I didn’t know that the VM uses it’s own console.
And the following post gave me the missing information to enable the console for the VM on my MAC.