WordPress Production-Ready Certified by Bitnami and Automattic

Keywords: WordPress - AWS - How to - Secure Connections (SSL/HTTPS)

Description:
Hello,

I have been testing WordPress Production-Ready Certified by Bitnami and Automattic for last 72 hours and I love so far. I have only two issues that I only see on the wordpress Site Health, but I do not know I have to solve or not.

  1. critical issue - Background updates are not working as expected
    Background updates ensure that WordPress can auto-update if a security update is released for the version you are currently using.

Error The WP_AUTO_UPDATE_CORE constant is defined and enabled.
Passed No version control systems were detected.
Passed Your installation of WordPress doesn’t require FTP credentials to perform updates.
Passed All of your WordPress files are writable.
Error WordPress security and maintenance releases are blocked by define( ‘WP_AUTO_UPDATE_CORE’, false );

  1. recommended improvement - Your website does not use HTTPS
    You are accessing this website using HTTPS, but your WordPress Address and Site Address are not set up to use HTTPS by default.

HTTPS is already supported for your website.
However, your WordPress Address is currently controlled by a PHP constant and therefore cannot be updated. You need to edit your wp-config.php and remove or update the definitions of WP_HOME and WP_SITEURL

Best regards,
Erik

Hello @erikdst,

Thanks for using our WP solution! Regarding the HTTPS issue, you can follow this guide replacing http with https:

https://docs.bitnami.com/aws/apps/wordpress-pro/administration/configure-domain/

As for the background updates, you can try changing the WP_AUTO_UPDATE_CORE variable in /opt/bitnami/wordpress/wp-config.php to true or minor instead of the default false.

Regards,
Francisco de Paz

Hello, thanks for the answer, how do I reach SSH on the bitnami production ready?

I found answer to my last question. My next question: is it necessary to resolve the ssl and update issues that a shown on the first message?, This deploy have been working well, for that my doubt

Hello @erikdst,

I would say it is not necessary, as HTTPS is already supported on your site and your users will be accessing it with the secure protocol.

Nevertheless, if you want to double-check, you can ask at WordPress official forums as they will be able to give you a more informative answer.

https://wordpress.org/support/forums/

Regards,
Francisco de Paz

Hello Francisco,

I think the same as you, maybe there are some reasons to have this that way on the deploy. By the way, this deploy (production ready) is easy to deploy and look so amazing. You at bitnami are awesome.

I have been using hosting for some year, but now we are moving to aws, so we are new on this. Is there a way to conntact or get any service for bitnami for any issue on the futere? I mean a service were someone can look your issue directly?

Thanks,
Erik

Hi @erikdst,

Thank you for your kind words :slight_smile:

Sorry @erikdst, we do not provide that kind of service. However, you can post all your questions in this forum and the team will take care of answering them.

Hello @jota, thanks for your answer :slight_smile:

Since last Sunday, I am using this implementation (ready for production) on my main website, so far so good.

I saw on the sslshopper website (dulcealud.cl), that the ssl is for one year, that’s great. My doubt is: Does the deploy renew the ssl or do I have to renew myself?

Do you recommend using a cache plugin (w3 total cache, litespeed, etc.) for this deploy? I have not found if the implementation uses its own system cache or something like that.

Sincerely,
Erik

Hello @erikdst,

From what I saw on the site, you are using Amazon to expedite the SSL certificate, is that right? In that case, I am pretty sure the certificate will be renewed automatically, or at least you have an option to enable it so. I recommend you to check with them to make sure about this.

Regarding the use of a cache plugin, you can use one to improve your site performance. You can check the following guide to get an idea of some of the available plugins and any configuration changes necessary:

https://docs.bitnami.com/aws/apps/wordpress-pro/troubleshooting/optimize-bitnami-wordpress/

Regards,
Francisco de Paz

Hello @fdepaz, thanks, I will check it with aws.

A strange thing that I found is : when I open dulcesalud.cl on firefox, only the home page say: that the ssl is not complete: Mixed content blocking in Firefox. I do not know if this happen on apple browser, but it is strange I think.

By the way, I do not know how this deploy works, but is amazing, I just update woocommerce and the side got “broken” I could not login the side or admin and I got a messege relate with mysql, but after a minute it got back and the update was done.

Thanks a lot,
Erik

Hello @erikdst,

Happy that you are liking our stack! Regarding the mixed content, that should have been solved when replacing HTTP with HTTPS as shown in the guide I linked previously. If you are still having issues, please create a new ticket in the forum using the “Technical issue” option when clicking on “+ New Topic”.

If you get any errors adding the bndiagnostic ticket ID when creating a “Technical issue” topic, please upgrade our bndiagnostic-tool. To do so, please download the latest version and run again the tool for it to generate a new ID.

Regards,
Francisco de Paz

Hello,

I just found this issue, and I did not find how to solve it: The www and non-www versions of your URL are not redirected to the same site.

Thanks a lot,
Erik

Hello @erikdst,

That should be because your SSL certificate is only for domain.cl and not www.domain.cl. It is a common best practice to allow access to both domains (with and without www.) and redirect the traffic of one of the domains to the other. For that, you will first need your certificate reissued and then modify your Apache configuration following this guide:

https://docs.bitnami.com/aws/apps/wordpress/administration/redirect-custom-domains/

Regards,
Francisco de Paz

Hello there,

Sorry to bother you again, but I’ve tried to connect via putty and use the commands line, but I can’t access config.php or your last link about Apache. I share a screenshot of all the steps.
Please, help me to see my error (my deploy is this: WordPress Production-Ready Certified by Bitnami and Automattic)

https://snipboard.io/uHJDGb.jpg
https://snipboard.io/FelIvu.jpg
https://snipboard.io/1DTH5d.jpg
https://snipboard.io/lczLj6.jpg
https://snipboard.io/UVWiwH.jpg
https://snipboard.io/qz4BQL.jpg
https://snipboard.io/Qzm5Cb.jpg
https://snipboard.io/0XcVFz.jpg
https://snipboard.io/HeMUoR.jpg
https://snipboard.io/yS9Mlx.jpg
https://snipboard.io/CJGABg.jpg

Thanks,

Hello @erikdst,

Could you please try following our guide on SSH connections:

https://docs.bitnami.com/aws/faq/get-started/connect-ssh/

Regards,
Francisco de Paz

Hello, I tried that before, on the connection-data I have to write ec2-user, it does not recognise bitnami. I show you below.
I installed my deploy as show here: https://docs.bitnami.com/aws-templates/apps/wordpress-production-ready/get-started/launch-production-ready-deployment/

https://snipboard.io/unKgNE.jpg
https://snipboard.io/YT0Nmx.jpg
https://snipboard.io/DsM13h.jpg
https://snipboard.io/7IVWfD.jpg

please help

Hello @erikdst,

My bad, I didn’t notice you were using a Multi-tier solution. In that case, please first enable ssh and connect to it via Bastion following these guides:

https://docs.bitnami.com/aws-templates/faq/get-started/enable-ssh/
https://docs.bitnami.com/aws-templates/apps/wordpress-production-ready/get-started/connect-ssh/#forward-your-key-using-ssh-agent-on-windows

Regards,
Francisco de Paz