WordPress - OpenSSL version different from ChangeLog

Keywords: WordPress - Google Cloud Platform - How to - Upgrade

Description:
Good afternoon,
I just deployed the WordPress Version 5.8.1-18-r07 / 2021-10-08 on Google Cloud, to update Apache, and I noticed the OpenSSL version is 1.1.1d. This is an issue for us because it will fail a PCI compliance scan.
I checked the CHANGELOG, on Version 5.7-2 / 2021-03-26, OpenSSL was updated to 1.1.1k.
How can I update OpenSSL to 1.1.1k ?

Thank you,
Julio

Hi @Julioc,

Please note that the changelog information only applies to the Bitnami installers. In your case, you are using a cloud image and we use the OpenSSL system’s package during the installation process. As you can see here, 1.1.1d-0+deb10u7 is the latest available version for OpenSSL in Debian Buster.

https://packages.debian.org/buster/openssl

Happy to help!


Was my answer helpful? Click on :heart:

Hi Jota.
Understood. Thank you for the clarification.

do you have a time frame to release the cloud image with Debian 11 - Bullseye?

Thank you,
Julio

Hi @Julioc,

It’s not in our roadmap in the short term because Debian 10 is fully supported right now but we will reconsider this in the future. Thanks for your interest.