Wordpress jobs queued up but server cron is actually running it

Keywords: WordPress - AWS - Technical issue - Other
bnsupport ID: 0c4f9f3e-c22d-6c10-9df9-986502e76690
Description:
Hi there,
I enabled “Enable Server Scheduler” and with crontab -e I added a 15 mins cron like this:

*/15 * * * * su daemon -s /bin/sh -c “cd /opt/bitnami/apps/wordpress/htdocs/; /opt/bitnami/php/bin/php -q wp-cron.php”

If I then check the log with grep “wp-cron.php” /var/log/syslog I see the cron is running:


Jan 11 20:30:01 ip-172-26-6-113 CRON[27778]: (bitnami) CMD (su daemon -s /bin/sh -c “cd /opt/bitnami/apps/wordpress/htdocs/; /opt/bitnami/php/bin/php -q wp-cron.php”)
Jan 11 20:45:01 ip-172-26-6-113 CRON[27887]: (bitnami) CMD (su daemon -s /bin/sh -c “cd /opt/bitnami/apps/wordpress/htdocs/; /opt/bitnami/php/bin/php -q wp-cron.php”)
Jan 11 21:00:01 ip-172-26-6-113 CRON[28056]: (bitnami) CMD (su daemon -s /bin/sh -c “cd /opt/bitnami/apps/wordpress/htdocs/; /opt/bitnami/php/bin/php -q wp-cron.php”)
Jan 11 21:15:01 ip-172-26-6-113 CRON[28164]: (bitnami) CMD (su daemon -s /bin/sh -c “cd /opt/bitnami/apps/wordpress/htdocs/; /opt/bitnami/php/bin/php -q wp-cron.php”)

However… all jobs at the /wp-admin/tools.php?page=advanced-cron-manager are halted in “In queue”.

Finally, if I do sudo su and then I execute

su daemon -s /bin/sh -c “cd /opt/bitnami/apps/wordpress/htdocs/; /opt/bitnami/php/bin/php -q wp-cron.php”

Then all jobs are run and wordpress see them as run.

Any idea what could be going on?

Thanks

Hello @marianopeck,

I can see you added it to bitnami crontab. Could you add this to root crontab with the command below?:

sudo crontab -e -u root

Also, let me share with you this previous similar thread in case it helps:
https://community.bitnami.com/t/scheduled-posts/48527/9

Regards

Thanks @davidg
I forgot to comment that yesterday night I also fixed it. I wasn’t aware of the -u root option in crontab so what I did was to first do sudo su and then within the root, do the crontab -e. But yes, you are right…I was running the cron with Bitnami user when I should have done it with root.

Thanks for your help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.