Wordpress Instance CPU Spike

Keywords: WordPress - AWS - Technical issue - Upgrade
Description:
I just migrated and upgraded to Lightsail Bitnami WordPress. This few days the site is not stable and i just commented out the pagespeed_mod as it block my content. After I commented out I still face website down. What is the issue? Please advise.

ac9b1039-e71f-cb1c-5461-bd341d7a8a22

Hi @liukang9368

Thanks for using Bitnami WordPress!

Our support tool has identified the following issues, could you please take a look at them?

? Apache: Found possible issues
? WordPress: Found possible issues
? resources: Found possible issues
? mysql: Found possible issues
? php: Found possible issues

Found recent error messages in the Apache error log.

[Wed Apr 21 08:57:45.541562 2021] [proxy_fcgi:error] [pid 7380:tid 140103175272192] [client 162.158.167.36:42958] AH01071: Got error 'PHP message: PHP Warning:  Invalid argument supplied for foreach() in /opt/bitnami/apps/wordpress/htdocs/wp-content/themes/norebro/parts/elements/panel.php on line 23'

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

The WordPress domain does not seem to be configured. Please check the following guide:

https://docs.bitnami.com/general/apps/wordpress/administration/configure-domain/

Found recent WordPress plugin related error messages in the Apache error log.Please check the following guide to deactivate plugins:

https://developer.wordpress.org/cli/commands/plugin/deactivate/

Your instance has little available RAM memory.You could try to increase your instance’s memory. Please check your cloud provider’s documentation for more information.

Found recent error messages in the MySQL error log:

2021-04-21T08:55:15.709736Z 0 [ERROR] [MY-010119] [Server] Aborting

Please check the following guide to troubleshoot MySQL issues:

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mysql/

The following error appears in the /opt/bitnami/php/var/log/php-fpm.log:

[21-Apr-2021 08:51:56] WARNING: [pool www] server reached max_children setting (5), consider raising it

This error usually indicates PHP script execution is slow due to busy server resouces or buggy scripts. Please check the following guide on how to increase the memory limit:

https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-options/

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.