WORDPRESS: ERROR: Failed to restart "apache": cannot start service

Hi There,

I am new to WordPress and considered that while I mocking up a new blog I liked the idea of working locally and publishing later…

  1. So I downloaded: bitnami-wordpress-5.4.2-0-osx-x86_64-vm.dmg to my mac running MacOS mojave 10.14.6.

  2. After the instalation I was able to get MySQL, PHP-FPM services working… However, I couldn’t get Apache to respond…

  3. This was the report from the Log:

ERROR: Failed to restart “apache”: cannot start service: AH00526: Syntax error on line 46 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf:
SSLCertificateFile: file ‘/opt/bitnami/apache2/conf/server.crt’ does not exist or is empty

  1. My Localhost forwarding rules seem to be enabled it is just the issue with the apache. I have not in any way modified the WordPress package I downloaded from Bitnami.

If anyone can help me figure out this problem I would be really greatful!!

Many Thanks,
Oli

Hi, @Starting_Blog.

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Sorry if this is a silly question…

Is the Bitnami support tool location described as the “installation directory of the stack at /opt/bitnami” aka… “code directory”, “stackman” or “stackman launcher”? I’m not sure if I need to “Manually upload the Bitnami Support Tool bundle”?

Apolagies

From the Stackman (OSX VM) menu, you can click “Open Terminal” to launch a console. In that console you can run the commands to execute the Bitnami Support Tool. You can follow this article for instructions on how to launch the terminal: https://docs.bitnami.com/installer/faq/osx-vm-faq/administration/access-console-osx-vm/

The tool should upload it automatically to our servers. You would only need to manually update it if that fails. The tool will warn you about it.

Ok, I see.

I have run the support tool…

However… I have now managed to avaoid this problem and get Apache, PHP-FRM, MySQL aswell to give a green light installing the Wordpress multisite version instead.

But when i click the go to aplication button and go to this url:
http://0.0.0.0/wp-signup.php?new=192.168.64.3
So the page doesn’t load.

I dont really know how I have managed to bypass the problem and get to this point where the page will not load.

my support ticket is: 19262cf7-0aa7-ea09-541c-d5e5dbf8ca1f

What IP do you see in the Stackman UI? What happens if you try to access http://192.168.64.3 ?

it appears I get 192.168.64.1 as the ip

However every time i try to use the http://192.168.64.3 ip it times out…

it appears that my internet connection however is fine…

For the standard wordpress the apache will still not load and i get the following error:

INFO: Starting “WordPress” stack
INFO: “WordPress” stack successfully started
INFO: Starting “php-fpm”
INFO: Successfully started “php-fpm”
INFO: Restarting “mysql”
INFO: Restarting “php-fpm”
INFO: Restarting “apache”
INFO: Successfully restarted “mysql”
ERROR: Failed to restart “apache”: cannot start service: AH00526: Syntax error on line 46 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf:
SSLCertificateFile: file ‘/opt/bitnami/apache2/conf/server.crt’ does not exist or is empty

INFO: Successfully restarted “php-fpm”

Using http://192.168.64.3 ip the response in firefox is server not found…

when using Wordpress multisite Apache works however, when clicking the ‘Go to Aplication’ and the browser directs me to http://192.168.64.3 i recieve the message from firefox saying: ‘Firefox Unable to connect, can’t establish a connection to the server at 0.0.0.0.’

the terminal says: the ‘root@192.168.64.3’

Since Apache doesn’t seem to be working, it is normal that Firefox can’t find the server.

Can you run these commands to try to fix the Apache server?

sudo mv /opt/bitnami/apache2/conf/server.crt.back /opt/bitnami/apache2/conf/server.crt
sudo mv /opt/bitnami/apache2/conf/server.key.back /opt/bitnami/apache2/conf/server.key

Then, restart the server:

sudo /opt/bitnami/ctlscript.sh restart apache

And try to access your site.

Regards,
Alejandro

That great thank you so much!!

I also wanted to ask about the ‘Multisite’ version of Wordpress, because Idealy I actualy have more than one domain I planed to use for two separate sites…

I really appolagie to ask for your help again as I know this was not my original queery but in the long run i think this instalation may be more suited for me. So I was wondering if you could give me a little help get this running it…

  1. I have installed now installed ‘Wordpress Multisite’

  2. “mysql”, "php-fpm"and “apache” all work

  3. However when I click; go to application

  4. This is the link: http://0.0.0.0/wp-signup.php?new=192.168.64.3
    [Firefox says: Firefox can’t establish a connection to the server at 0.0.0.0.]

Many Thanks!

Does the site show if you go to http://192.168.64.3 instead?

Firefox says: Unable to connect

Firefox can’t establish a connection to the server at 0.0.0.0.

Hi @Starting_Blog,

Can you open the the command line of the VM and run these commands?

curl -LI localhost
curl -LI 192.168.64.3 

Please share the output of those command here.

Thanks

Unfortunately the same output in the browser…

Last login: Tue Jun 30 13:47:52 2020 from 192.168.64.1
root@debian:~# Can you open the the command line of the VM and run these
commands?
-bash: Can: command not found
root@debian:~#
root@debian:~# curl -LI localhost
HTTP/1.1 302 Found
Server: Apache
X-Powered-By: PHP/7.3.18
X-Frame-Options: SAMEORIGIN
Vary: Cookie
Location: http://0/wp-signup.php?new=localhost
Content-Type: text/html; charset=UTF-8

HTTP/1.1 400 Bad Request
Server: Apache
X-Frame-Options: SAMEORIGIN
Connection: close
Content-Type: text/html; charset=iso-8859-1

root@debian:~# curl -LI 192.168.64.3
HTTP/1.1 302 Found
Server: Apache
X-Powered-By: PHP/7.3.18
X-Frame-Options: SAMEORIGIN
Vary: Cookie
Location: http://0/wp-signup.php?new=192.168.64.3
Content-Type: text/html; charset=UTF-8

HTTP/1.1 400 Bad Request
Server: Apache
X-Frame-Options: SAMEORIGIN
Connection: close
Content-Type: text/html; charset=iso-8859-1

root@debian:~#

the log says…

ERROR: Failed to restart “php-fpm”: cannot start service: Process exited
with status 3

Hi @Starting_Blog,

It seems the machine was not properly initialized and that’s why you are getting those weird errors. Could you please try to uninstall that deployment and launch a new Bitnami WordPress solution from scratch?

https://docs.bitnami.com/installer/faq/osx-vm-faq/administration/uninstall-osx-vm/

Once you uninstall it, and before starting the new VM, please ensure your machine has enough resources to run the VM.

Thanks and sorry for the inconvenience.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.