Wordpress Crash - Requires restarting web server to go back up

Keywords: WordPress - AWS - Technical issue - Other
bnsupport ID: ed73ccb0-6097-4c9b-fc20-3b141b62f7d8
Description:
The website constantly crashes every hour or two, and doesn’t go back up until we restart the server.

Have done the following:

  • checked apache error logs: saw two errors, that are heavily repeated:

[Tue Apr 06 02:32:16.114897 2021] [pagespeed:error] [pid 3013:tid 140198872413952] [mod_pagespeed 1.13.35.2-0 @3013] PageSpeed Serf fetch failure rate extremely high; only 1 of 90 recent fetches fully successful; is fetching working?

[Tue Apr 06 03:38:46.754519 2021] [proxy_fcgi:error] [pid 3013:tid 140199984240384] (70007)The timeout specified has expired: [client 34.235.153.217:40298] AH01075: Error dispatching request to : (reading input brigade), referer: http://34.235.153.217/_ignition/execute-solution

Any help would be greatly appreciated.

Thanks.

Hi @jad,

Can you run the bndiagnostic tool? It will run a quick diagnose of the most common issues and share possible solutions.

sudo /opt/bitnami/bndiagnostic-tool 

Regards,
Michiel

Hello Michiel,

Thank you for your response.

I got the following:

? Apache: Found possible issues
? WordPress: Found possible issues
✓ Resources: No issues found
✓ Database: No issues found
  1. Found recent error messages in the Apache error log.
[Tue Apr 06 16:43:56.416863 2021] [core:error] [pid 11821:tid 139743757718848] AH00046: child process 11967 still did not exit, sending a SIGKILL

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

  1. Some files don’t have the expected permissions Please check the following guide:

https://docs.bitnami.com/general/apps/wordpress/administration/understand-file-permissions/

Hi @jad,

It seems the instance has little available RAM memory. I recommend upgrading the instance:

https://docs.bitnami.com/aws/faq/administration/upgrade-ami/

Regards,
Michiel

I did upgrade to a bigger instance, yet the issue persists.

Any advice?

eee33021-6eb8-630f-98a7-df51af1f1a8e

Hi @jad,

Could you try resetting the permissions?

sudo chown -R bitnami:daemon /opt/bitnami/apps/wordpress/htdocs
sudo find /opt/bitnami/apps/wordpress/htdocs -type d -exec chmod 775 {} \;
sudo find /opt/bitnami/apps/wordpress/htdocs -type f -exec chmod 664 {} \;
sudo chmod 640 /opt/bitnami/apps/wordpress/htdocs/wp-config.php 

Regards,
Michiel

Done, will monitor for 24 hours and let you know.

Thanks Michiel.

Faced the same issue 02ffc6ce-9ad5-33de-70dd-c9445302d6a

Hi @jad,

The following error appears in the /opt/bitnami/php/var/log/php-fpm.log:

[19-Apr-2021 20:43:16] WARNING: [pool www] server reached max_children setting (5), consider raising it

This error usually indicates PHP script execution is slow due to busy server resouces or buggy scripts. Please check the following guide on how to increase the memory limit:

https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-options/

Regards,
Michiel

I think its high, it’s at 512M now, can it go higher?

increased to 1GB, don’t know if that is healthy. Will monitor

Same issue; ad029d06-bc9d-f459-ec70-b5cbc798f430

what’s weird is that our PHP error log is empty.

Hi @jad,

There was a typo in the last message from @michiel. The problem is not with the memory limit configuration, it’s with the max_children configuration of PHP-FPM. You will need to edit the /opt/bitnami/php/etc/bitnami/common.conf file and increase that value. Remember to restart the services later.

Happy to help!


Was my answer helpful? Click on :heart:

Done took it from 25 to 250
will monitor and let you know.

Thanks Jota.

same issue unfortunately:
4c789068-595a-54f3-e11f-f64d00e2ccba

Hi @jad,

Did you restart php-fpm?

 sudo /opt/bitnami/ctlscript.sh restart php-fpm

Can you tell me the output of this command:

 ps aux | grep "php-fpm: pool"

Regards,
Michiel