Why does bitnami service keeps starting mysqld although disabled from gonit?

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Other
Description:
I’m trying to completely disable mariadb, disabled it from
gonit stop mariadb
/etc/monit/conf.d/mariadb.conf.disabled
gonit reload

the service is no longer on gonit however it’s still started under the bitnami service, I killed it restarted bitnami service and here it is starting again

● bitnami.service - LSB: bitnami init script
   Loaded: loaded (/etc/init.d/bitnami; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2021-06-24 23:04:56 UTC; 18min ago
  Process: 1258 ExecStart=/etc/init.d/bitnami start (code=exited, status=0/SUCCESS)
    Tasks: 51 (limit: 1133)
   Memory: 247.4M
   CGroup: /system.slice/bitnami.service
           ├─1084 /opt/bitnami/gonit/bin/gonit
           ├─1362 php-fpm: master process (/opt/bitnami/php/etc/php-fpm.conf)
           ├─1367 php-fpm: pool www
           ├─1368 php-fpm: pool www
           ├─1369 php-fpm: pool www
           ├─1370 php-fpm: pool www
           ├─1371 php-fpm: pool www
           ├─1372 php-fpm: pool www
           ├─1373 php-fpm: pool www
           ├─1374 php-fpm: pool www
           ├─1375 php-fpm: pool www
           ├─1387 /opt/bitnami/mariadb/sbin/mysqld --defaults-file=/opt/bitnami/mariadb/conf/my.cnf --basedir=/opt/bitnami/mariadb --data
           ├─1441 nginx: master process /opt/bitnami/nginx/sbin/nginx -c /opt/bitnami/nginx/conf/nginx.conf
           ├─1442 nginx: worker process
           ├─1443 nginx: worker process
           └─1584 php-fpm: pool www

Hello @mo2menelzeiny,

Could you please take a look at this previous case?

I hope it helps

1 Like

@davidg
I’ve looked at that post of course, however it’s not the case. I’m suspecting is a bug here.
reasons:

  • in the current bitnami image version there are no /mariadb/scripts/ctl.sh there is a /opt/bitnami/scripts/mariadb/start.sh
  • I found this https://docs.bitnami.com/aws/apps/wordpress/administration/configure-use-varnish/ and after following the same way varnish is disabled from their docs
    [ -f /opt/bitnami/scripts/varnish/start.sh.disabled ] && sudo mv /opt/bitnami/scripts/varnish/start.sh.disabled /opt/bitnami/scripts/varnish/start.sh
    but for mariadb the /etc/init.d/bitnami script that backs the bitnami service started complaining and failing to provision due to the fact it cant find the mariadb start script which means that it’s totally ignoring my /etc/monit/conf.d/mariadb.conf.disabled and trying to start mariadb anyways by looking for /opt/bitnami/scripts/mariadb/start.sh and failing when not finding it

the golden question is why is the bitnami init trying to start mariadb at all even though gonit is disabled?

Hi @mo2menelzeiny,

You are right, I just disabled MariaDB in a fresh installation using this commands

sudo mv /etc/monit/conf.d/mariadb.conf /etc/monit/conf.d/mariadb.conf.disabled
sudo gonit reload
sudo /opt/bitnami/ctlscript.sh status

More info here: How to stop mariaDB from EC2 running on Debian?

and ensured that the database was stopped. Once I ran the sudo service bitnami restart command, the MariaDB database got started again. The team is going to investigate it and provide a solution to you.

1 Like

Hi @mo2menelzeiny

Thanks for reporting this issue! This is something we already fixed but the new version of the “WordPress + NGINX + SSL” including this fix hasn’t been released on AWS (yet). I’ll try to speed up the release process.

For instance, if you a launch in AWS the “Bitnami WordPress” solution (the one including Apache), this image already include the fix.

So it’s just a matter of waiting for the new image to be published. I’ll notify you as soon as it’s published.

Best regards,

Juan Ariza

1 Like

Hi @mo2menelzeiny

Could you please give a try to the new image (5.7.2-24) that we just release? Find the AMI(s) in the links below:

Best regards,

Juan Ariza

1 Like

Alright, will let you know!

@jariza, Hey

Thanks for the quick support.

I just tested it and it seems that the issue has been resolved.

Thanks for letting us know!! I will close the ticket then. If you find another issue, do not hesitate to open a new thread.