Where can I find Rubystack 2.3.4-0?

Hello,
The latest Bitnami Ruby installer for Windows (2.3.6-4) contains Ruby 2.3.3. But this Ruby version is known as buggy.

Where could I find the Ruby Installer 2.3.4-0 which contains Ruby 2.3.4 ?

Thanks
Mario

Hi,

You can download the Windows installer using the following link:

md5:a273c8e01c7682cf8b886c5b2578484a

If you need another version or platform (Linux, OSx, VMs, etc) do not hesitate to let us know.

Best regards,
Carlos R. Hernández

Hi Carlos,

Thanks a lot for your responsiveness.
I install it soon.

Best regards
Mario

Hi Carlos,

I am disappointed !

The Windows Rubystack Installer 2.3.4-0 contains Ruby 2.3.3 (although the changelog says it should contain Ruby 2.3.4).
The same happens with the RubyStack Installers 2.3.6-4 and 2.2.9-1 : they all install Ruby 2.3.3 in fact.

I need a Ruby version 2.3.X where X > 3, and a Node.js >= 6.11.5.

In which Rubystack installer may I find these for Windows ?

Thank you for your help.
Mario

Hi,

Are you running ruby -v inside the ruby console? I mean, Bitnami Stacks provides a console where the components inside the stack, paths and variables are loaded by default. If you run ruby -v without the console, you are obtaining the ruby version installed on the system (it should be a ruby version installed on your windows machine). To use the ruby provided by the Bitnami stack you should load this environment or console.

On Windows, you can do it using the shortcut in the Start menu under “Start -> Bitnami Ruby Stack -> Use Ruby”. Once the Ruby console has loaded, execute a Ruby command as you normally would.

For example, in my case (using Linux installer instead of the Windows one, but it should be the same). Without load the environment:

$ ruby -v
ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-linux]

this is the system ruby.

If I load the environment:

$ sudo ./rubyconsole
$ ruby -v
ruby 2.3.6p384 (2017-12-14 revision 61254) [x86_64-linux]

now, the ruby version is different, it is 2.3.6 because I installed rubystack-2.3.6-4.

Can you perform these checks and tell us the result?

Best regards,
Carlos R. Hernández

Hi Carlos,

I already have 2 Bitnamy Rubystack environments installed which work perfectly when I launch use_ruby.bat (the equivalent of sudo ./rubyconsole for windows I guess) in the Bitnami installation directory : I get the right Ruby version for each of the 2 environnements (which are rubystack-1-9-3-27 and rubystack-2.2.5-4).

Anyway, when I launch a DOS command prompt and I launch ruby -v, I get ruby 1.9.3p550 (2014-10-27) [i386-mingw32]

When I enter my C:\Bitnami\rubystack-2.2.9-1 directory for instance (by cd C:\Bitnami\rubystack-2.2.9-1 in the DOS command prompt), I launch use_ruby.bat at the command prompt : a new window is opening on C:\Bitnami\rubystack-2.2.9-1.

I then enter ruby -v and I get ruby 2.3.3p222 (2016-11-21 revision 56859) [i386-mingw32]

When I enter node -v I get V6.13.0 which is the version announced in the changelog for Rubystack-2.2.9-1 (at a DOS command prompt, without bitnami, I get V4.2.4 for the command node -v)

I am a bit lost !

Best regards
Mario

A precision (I wish it is useful).

I launch a DOS console
I enter cd C:\Bitnami\rubystack-2.2.9-1\ruby\bin
I am now in the C:\Bitnami\rubystack-2.2.9-1\ruby\bin directory
I then enter ruby.exe -v
And I get ruby 2.3.3p222 (2016-11-21 revision 56859) [i386-mingw32]

Hope it helps
Best regards
Mario

Hi @commande.castellazzi,

Sorry for the inconvenience but we take the Windows binaries from https://rubyinstaller.org/ and they have not published that version of Ruby yet. As this is taking longer to publish, we continued releasing the installers with the previous version and planned to update the installers once the new version is published.

In case you need that specific version of ruby, I suggest you use the Bitnami Virtual Machines with the latest version of Ruby.

https://bitnami.com/stack/ruby/virtual-machine

We will review this information in case we mixed the ruby versions. Thanks for reporting this error.

OK, thank you for your reply.

Bitnami Rubystack is a great product.

Best regards
Mario

Hi @commande.castellazzi,

Thank you for your kind words. Regarding the wrong Ruby version in the installer, we could reproduce it and we are working on releasing a new revision of the installer including the latest Ruby version for Windows.

Thanks.

Hi Jota,

Good news !!!
I am looking forward this new version.

Have a nice day
Mario

Hi @commande.castellazzi,

Just to let you know that we have released a new version of the Bitnami Ruby Stack that has the correct version for 2.2.X installers as you can see in the changelog: https://bitnami.com/stack/ruby/changelog.txt. Thanks for reporting it.

Regarding the Ruby 2.3.4 installer for Windows, as @jota mentioned, we will be able to release it once it is available here: https://rubyinstaller.org/downloads/.

You can subscribe to the Bitnami Ruby Stacks by clicking on the image button here: https://bitnami.com/stack/ruby. That way you will be notified when new versions of the Stack are released.

Best regards,
Andrés Bono.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.