When is the Next Upgrade of Apache from 2.4.46 to (something higher)?

Keywords: General - Other - Technical issue - Upgrade
Description:
For Magento with Azure Database for MySQL (Azure Application)
We’re having a problem with a PCI Scan
Vulnerability : CVE-2021-30641
Affected Versions: Apache HTTP Server versions prior to 2.4.46.
Current Apache Version on Bitnami Magento : 2.4.46.

When will you be updating Apache from 2.4.46 to (something higher : 2.4.8 i assume ?) ?

In addition, could you point us to the docs or instructions to update it to the latest version, once the update is available.

Cheers,

Hi @dmartinet10

Thanks for using Bitnami Magento and notifying us!

The reporting vulnerability is classified as Moderate/Medium by several reporting sites:
https://ubuntu.com/security/CVE-2021-30641
https://access.redhat.com/security/cve/cve-2021-30641

Our release flow is usually triggered automatically when a new version of Magento is released, or when a severe CVE is disclosed. Nevertheless, I have just triggered a new release manually and you should expect the new version soon, thanks again for the report!

In addition, could you point us to the docs or instructions to update it to the latest version, once the update is available.

The recommended way is to perform a backup of your current instance and migrate to a new one, running the latest version. We have the process documented in one of our guides, here you have it :slightly_smiling_face:

https://docs.bitnami.com/google/apps/magento/administration/backup-restore/
https://docs.bitnami.com/google/apps/magento/administration/backup-restore-mysql-mariadb/

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Thank you,

Could we have an ETA of when a new version might be up ?

Cheers,

Should be fixed by now on Azure!

Bitnami Magento 2.4.2-2 is out on Azure, and it features Apache 2.4.48

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.