When I execute these commands, I get errors

Keywords: Mautic - AWS - How to - Connectivity (SSH/FTP)

Description:
i launched an Ec2 AWS instance with the mautic application (debian 10)
I’m trying to install Geolip Maximind on my instance but without success.
here is the tutorial I follow: https://mauteam.org/mautic/mautic-admins/solved-maxmind-geolite2-database-not-updating/

Here are the problems

when I execute the command add-apt-repository ppa:maxmind/ppa
I get the result
More info: https://launchpad.net/~maxmind/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox ‘/tmp/tmpxsjdtonq/pubring.gpg’ created
gpg: /tmp/tmpxsjdtonq/trustdb.gpg: trustdb created
gpg: key DE1997DCDE742AFA: public key “Launchpad PPA for MaxMind” imported
gpg: Total number processed: 1
gpg: imported: 1
gpg: no valid OpenPGP data found.

when I execute the command apt update
I get the result

Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://cdn-aws.deb.debian.org/debian buster InRelease
Hit:3 http://cdn-aws.deb.debian.org/debian buster-updates InRelease
Hit:4 http://cdn-aws.deb.debian.org/debian buster-backports InRelease
Ign:5 http://ppa.launchpad.net/maxmind/ppa/ubuntu impish InRelease
Err:6 http://ppa.launchpad.net/maxmind/ppa/ubuntu impish Release
404 Not Found [IP: 91.189.95.85 80]
Reading package lists… Done
E: The repository ‘http://ppa.launchpad.net/maxmind/ppa/ubuntu impish Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I didn’t think it was useful to continue the tutorial because of these errors. I need your precious help to correct them.

Hi @sopemmanuel,

We helped another user to install the library and the module here

Did you take a look at it? Please note that the Bitnami images use Debian and not Ubuntu.

Happy to help!


Was my answer helpful? Click on :heart:

Hi thank you for your help.
When I execute the command apt-get update
I get this error

    Hit:1 http://security.debian.org/debian-security buster/updates InRelease
    Hit:2 http://cdn-aws.deb.debian.org/debian buster InRelease
    Hit:3 http://cdn-aws.deb.debian.org/debian buster-updates InRelease
    Hit:4 http://cdn-aws.deb.debian.org/debian buster-backports InRelease
    Ign:5 http://ppa.launchpad.net/maxmind/ppa/ubuntu impish InRelease
    Err:6 http://ppa.launchpad.net/maxmind/ppa/ubuntu impish Release
      404  Not Found [IP: 91.189.95.85 80]
    Reading package lists... Done
    E: The repository 'http://ppa.launchpad.net/maxmind/ppa/ubuntu impish Release' does not have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

how can I do

Hi @sopemmanuel,

As I mentioned, the Bitnami images use Debian, not Ubuntu and you added an Ubuntu repository to the machine and it’s throwing errors. To delete that repo, please edit the /etc/apt/sources.list file and remove the entry there. You can also find useful information here

https://unix.stackexchange.com/questions/219341/how-to-apt-delete-repository