What to Delete in /dev/sdal is over bloated more than 1.2 TB

Keywords: WordPress Multisite - Microsoft Azure - How to - Services (Apache, MariaDB, MySQL…)

Description:
We are having an issue with our BitnamiWordpress Multisite where our Database is over-bloated and taking too much space and we are not sure what to do to Decrease it.

Running Bitnami on AZure with Multisite WordPress

Keeps adding on daily basis and we are not sure what to remove or to delete so we are back on track or What is causing the large Space on the server

Am sharing all our Bitnami INFO on this link because i could not get the Code from the support Tool
Link to All info
https://www.dropbox.com/sh/kdqz1elu3caq5yp/AABkEHCfhLjcydaAI7GWmHpQa?dl=0

We urgently need some help and direction on what to do at this point.

Also below is some other info that can be useful to you

â Php: No issues found
? Resources: Found possible issues
â Apache: No issues found
? Connectivity: Found possible issues
? Mysql: Found possible issues
[Resources]

Your disk is almost full: You could try to increase your instance’s storage.

Filesystem Size Used Avail Use% Mounted on /dev/sda1 1.2T 1.1T 59G 95% /
Please check your cloud provider’s documentation for more information.

Your instance has little available RAM memory.

total used free shared buff/cache available Mem: 16044 7933 401 355 7710 7422
Press [Enter] to continue:
Swap: 0 0 0
You could try to increase your instance’s memory. Please check your cloud
provider’s documentation for more information.

You can also enable swap memory to improve performance.

https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-m
emory-linux/

[Connectivity]

Server ports 22, 80 and/or 443 are not publicly accessible. Please check the
following guide to open server ports for remote access:

https://docs.bitnami.com/general/faq/administration/use-firewall/

[Mysql]

The “/opt/bitnami/mysql/data” folder is using 85% of total disk space.

1 /opt/bitnami/mysql/data/mysql
1 /opt/bitnami/mysql/data/sys
Press [Enter] to continue:
1014783 /opt/bitnami/mysql/data/bitnami_wordpress
1 /opt/bitnami/mysql/data/#innodb_temp
2 /opt/bitnami/mysql/data/performance_schema
1036099 /opt/bitnami/mysql/data
In most cases this is due to binary logging. Please check the following guide to
disable it.

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/disable-bi
nary-logging-mysql/

===== End of bndiagnostic tool output =====

Thank you i look forward to hear from you

Walid

Hi @wjawdeh,

It seems MySQL is using a lot of resources, for which I recommend disabling MySQL logging:

https://docs.bitnami.com/aws/infrastructure/mysql/troubleshooting/disable-binary-logging-mysql/

And purge the existing binary logs as explained in this thread:

Regards,
Michiel

Hello Michiel

I tried these settings but nothing happened. Following is the my.cnf configuration

[mysqladmin]
user=

[mysqld]
basedir=/opt/bitnami/mysql
datadir="/opt/bitnami/mysql/data"
port=3306
socket=/opt/bitnami/mysql/tmp/mysql.sock
tmpdir=/opt/bitnami/mysql/tmp
max_allowed_packet=32M
bind-address=127.0.0.1
skip-name-resolve=1
binlog_expire_logs_seconds=43200
character-set-server=utf8mb4
collation-server=utf8mb4_general_ci
disable_log_bin

default-authentication-plugin=mysql_native_password
[client]
port=3306
socket=/opt/bitnami/mysql/tmp/mysql.sock

default-character-set=utf8mb4
[manager]
port=3306
socket=/opt/bitnami/mysql/tmp/mysql.sock
pid-file=/opt/bitnami/mysql/tmp/manager.pid
default-mysqld-path=/opt/bitnami/mysql/bin/mysqld.bin

!include /opt/bitnami/mysql/bitnami/my.cnf

Any Ideas?

Thank you

Hi

I tried these settings but nothing happened. Following is the my.cnf configuration

[mysqladmin]
user=

[mysqld]
basedir=/opt/bitnami/mysql
datadir="/opt/bitnami/mysql/data"
port=3306
socket=/opt/bitnami/mysql/tmp/mysql.sock
tmpdir=/opt/bitnami/mysql/tmp
max_allowed_packet=32M
bind-address=127.0.0.1
skip-name-resolve=1
binlog_expire_logs_seconds=43200
character-set-server=utf8mb4
collation-server=utf8mb4_general_ci
disable_log_bin

default-authentication-plugin=mysql_native_password
[client]
port=3306
socket=/opt/bitnami/mysql/tmp/mysql.sock

default-character-set=utf8mb4
[manager]
port=3306
socket=/opt/bitnami/mysql/tmp/mysql.sock
pid-file=/opt/bitnami/mysql/tmp/manager.pid
default-mysqld-path=/opt/bitnami/mysql/bin/mysqld.bin

!include /opt/bitnami/mysql/bitnami/my.cnf

Any ideas on how to solve this?

Tx

Hi @wjawdeh,

Did you purge the binary logs?

 PURGE BINARY LOGS BEFORE ‘2021-08-20 00:00:00’;  

Please change the date to later if needed.

Regards,
Michiel

Hello again

Yes we ran the Command and purged the binary Log - But no changes at all - Our space is still the same
Any ideas? or can you provide a 1 one 1 Support ?

Thank you

Hello again
Please reminder

Yes we ran the Command and purged the binary Log - But no changes at all - Our space is still the same
Any ideas? or can you provide a 1 one 1 Support ?

Thank you

Hi @wjawdeh,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool in a cloud image or virtual machine

Please note that you need to paste the code ID that is shown at the end. In case you can’t upload it, I’ve shared my email address through a private message. Could you share the dropbox link there and notify me in this thread after sending it?

Regards,
Michiel

Hello michiel
I ran the tool but i don’t see a code anywhere- I did not receive a private message from you to share the outcome of the tools- I have the Zip file on my dropbox
Do u mind sending a private message again

tx
Walid

Hi @wjawdeh,

Sorry, my mistake, I’ve sent it now.

Regards,
Michiel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.