Website sent an invalid response. ERR_SSL_PROTOCOL_ERROR

Keywords: WordPress - Google Cloud Platform - Technical issue - Secure Connections (SSL/HTTPS)

bnsupport ID: 2888e4da-8ff9-3e21-005a-3642f8099eb0

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
? Php: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/
https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/

bndiagnostic failure reason: The documentation did not make any significant change

Description:
I can not access my website anymore . The problem first happend when i tried to autorenew my SSL certificate.

Even when i follow those step here :

https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/#step-1-install-the-lego-client

It doesn’t help . I’ve tried everything i could do, but still can’t access the website .

Hello @agservice.its,

It seems you are running almost out of storage:

-----------------------------------
Check free amount of disk space
-----------------------------------
Running: df -h
In: /opt/bitnami

Output:

Filesystem      Size  Used Avail Use% Mounted on
udev            840M     0  840M   0% /dev
tmpfs           171M   13M  158M   8% /run
/dev/sda1       9.8G  8.8G  558M  95% /
tmpfs           851M     0  851M   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           851M     0  851M   0% /sys/fs/cgroup

Could you try if resizing the server solves al the issues? Find below our documentation:
https://docs.bitnami.com/google/faq/administration/change-server-type

Apart from that, could you please take a look at this previous similar case?

Regards

Hello @davidg . I tried resizing the server following the Link you posted in your response and it did not help . Still getting the same issue .

I also took a look at the case you posted and tried to fix it following the instruction there but still getting the same error message !

Hi @agservice.its,

Could you please send a new support tool output with the latest changes so we can check them?

Regards

===== Begin of bndiagnostic tool output =====

✓ Mysql: No issues found
? Apache: Found possible issues
? Resources: Found possible issues
✓ Processes: No issues found
✓ Connectivity: No issues found
✓ Php: No issues found

[Apache]
Found recent error or warning messages in the Apache error log.

[Mon Jan 17 13:42:17.420696 2022] [core:error] [pid 13757:tid 140013232609024] 
[client **ip_address**:45920] AH00126: Invalid URI in request 'bin/sh' 'POST 
/cgi-bin/.%2e/.%2e/.%2e/.%2e/bin/sh HTTP/1.1'

Please check the following guide to troubleshoot server issues:
Press [Enter] to continue:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

[Resources]
Your disk is almost full: You could try to increase your instance’s storage.

Filesystem Size Used Avail Use% Mounted on /dev/sda1 9.8G 8.5G 784M 92% /

Please check your cloud provider’s documentation for more information.

===== End of bndiagnostic tool output =====

Press [Enter] to continue:
The diagnostic bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
6e401eb8-5236-04c3-4c54-f57eee43cdf9

Hello @agservice.its,

I can see this line at the end of /opt/bitnami/apache2/conf/bitnami/httpd.conf.

Include "/opt/bitnami/apache2/conf/bitnami/httpd.conf"

Could you please delete it and restart apache?

sudo /opt/bitnami/ctlscript.sh restart apache

Regards

I remove and restarted but still don’t work .

It was included on /opt/bitnami/apache2/conf/httpd.conf , not on /opt/bitnami/apache2/conf/bitnami/httpd.conf

I made a new diagnostic , here is the result :

===== Begin of bndiagnostic tool output =====

✓ Mysql: No issues found
? Apache: Found possible issues
? Resources: Found possible issues
✓ Processes: No issues found
✓ Connectivity: No issues found
✓ Php: No issues found

[Apache]
Found recent error or warning messages in the Apache error log.

[Mon Jan 17 13:42:17.420696 2022] [core:error] [pid 13757:tid 140013232609024] 
[client **ip_address**:45920] AH00126: Invalid URI in request 'bin/sh' 'POST 
/cgi-bin/.%2e/.%2e/.%2e/.%2e/bin/sh HTTP/1.1'
 [Thu Jan 20 01:46:50.317466 2022] [core:error] [pid 14001:tid 140013291357952] 
[client **ip_address**:42886] AH00126: Invalid URI in request 'bin/sh' 'POST 
/cgi-bin/.%2e/.%2e/.%2e/.%2e/bin/sh HTTP/1.1'
Press [Enter] to continue:

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-erro
rs-apache/
[Resources]
Your disk is almost full: You could try to increase your instance’s storage.

Filesystem Size Used Avail Use% Mounted on /dev/sda1 9.8G 8.5G 784M 92% /

Please check your cloud provider’s documentation for more information.

===== End of bndiagnostic tool output =====

Press [Enter] to continue:
The diagnostic bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
399f1d61-5c70-cc43-9e07-4de20004e9da
And paste it in your Bitnami Support ticket.

Hello @agservice.its,

I’ve just noticed this line was included in old installations. Please undo that change and uncomment these lines from your /opt/btinami/apache2/conf/bitnami/bitnami.conf file:

#SSLEngine on
#SSLCertificateFile “/opt/bitnami/apache2/conf/server.crt”
#SSLCertificateKeyFile “/opt/bitnami/apache2/conf/server.key”

Restart Apache after that.

Regards

1 Like

After uncommenting these libes and restarting Apache, i receive the following error message :

Unmonitored apache
AH00526: Syntax error on line 52 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf:
SSLCertificateFile: file ‘/opt/bitnami/apache2/\xe2\x80\x9c/opt/bitnami/apache2/conf/server.crt\xe2\x80\x9d’ does not exist or is empty
apache config test fails, aborting
AH00526: Syntax error on line 52 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf:
SSLCertificateFile: file ‘/opt/bitnami/apache2/\xe2\x80\x9c/opt/bitnami/apache2/conf/server.crt\xe2\x80\x9d’ does not exist or is empty
apache config test fails, aborting
Monitored apache

Hi @agservice.its,

You need to substitute these lines

SSLCertificateFile “/opt/bitnami/apache2/conf/server.crt”
SSLCertificateKeyFile “/opt/bitnami/apache2/conf/server.key”

with these ones

SSLCertificateFile "/opt/bitnami/apache2/conf/server.crt"
SSLCertificateKeyFile "/opt/bitnami/apache2/conf/server.key"

Note the vs " characters. I think you may have used a text editor when editing that file that introduced those. They look really similar but it’s important to use the correct one when configuring the SSL certificates. In case you do not know how to write that character, you can copy it from the DocumentRoot line.

Regards

1 Like

Thanks for that david !
Now i receive another error message on my browser , when trying accessing the website.

NET::ERR_CERT_INVALID

Subject: www.example.com

Issuer: www.example.com

Expires on: 18.06.2030

Current date: 21.01.2022

PEM encoded chain:
-----BEGIN CERTIFICATE-----
MIIDOTCCAiECFAsGQuvPKfEkrs2ZcQRsRsgRwe9mMA0GCSqGSIb3DQEBCwUAMFkx
EDAOBgNVBAoMB0JpdG5hbWkxKzApBgNVBAsMIkNlcnRpZmljYXRlIGdlbmVyYXRl
ZCBhdCBib290IHRpbWUxGDAWBgNVBAMMD3d3dy5leGFtcGxlLmNvbTAeFw0yMDA2
MjAxNDQ3NTNaFw0zMDA2MTgxNDQ3NTNaMFkxEDAOBgNVBAoMB0JpdG5hbWkxKzAp
BgNVBAsMIkNlcnRpZmljYXRlIGdlbmVyYXRlZCBhdCBib290IHRpbWUxGDAWBgNV
BAMMD3d3dy5leGFtcGxlLmNvbTCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoC
ggEBAMCMesRxIOGIimdElCCwV6Cs0Fv8P1yIhV7zV8nVf23CatcLMysvy42ggKLA
UO7ae55RwBvGockSIk+x3xjt4OImnE6vB3jLpGm+ygiHdUTnpvhaLNwaVeTZ/dJd
qY6HY36t0hgjXLVrsITd8Nsmmke/CTQk6s6lA3EFJi33MQpulACEVbGz97FfFyl3
JYXzdnLakgBLRDTjETvi6Og7jkowyBMquHQNbU3KR+7KH8/md5qSibHqFFIUc3jN
xhByV67BQRZ9L6wzzvkMcnsYIxz1Nm9n7ZxNs041CnIIzQf6E56TZ54gF8K6sZks
EQtEtp7esl0vgZSmh/aMae5efhECAwEAATANBgkqhkiG9w0BAQsFAAOCAQEAiMyp
MBpQQ/2YGUdfVXyob7Qx0ulT8XFyoCWM6DxSW0TrI2oGhr/dkE9DLUrS6RjbT8B8
NYYPYC9iPEk0eWtS7TDnEqbfuGYIv1E1P/4LYXb2qxClJM4RP7rCcvJvnqE1IFgu
A0kEMRgGfwXuuVzdp3P+PNpZWoGCZnr5/FHHxwBKbBcv5X4dj/NjS/4Jr8TWZ6O6
Lk8rAbvqrYnsfnENehDjEfVshTvnkw9Td+CsK6sfr8/zP2fmNfVG5NXQn8BK5D/V
TGb+I/VXhC4rMMbIt6jZFknH1L/xgCCyMkthAY6HhkT/15R+MLXTzajACAlyMGTT
dmChcKM+59I9Yp7HhQ==
-----END CERTIFICATE-----

I started a diagnostic again and here is the result :

===== Begin of bndiagnostic tool output =====

✓ Mysql: No issues found
? Apache: Found possible issues
? Resources: Found possible issues
✓ Processes: No issues found
✓ Connectivity: No issues found
? Php: Found possible issues

[Apache]
Found recent error or warning messages in the Apache error log.

[Thu Jan 20 18:21:02.496726 2022] [proxy_fcgi:error] [pid 8229:tid 
140121890285312] (-102)Unknown error -102: [client **ip_address**:3436] AH01075: 
Error dispatching request to :443: (reading input brigade)
 [Thu Jan 20 18:21:07.483588 2022] [core:error] [pid 8227:tid 140121990997760] 
[client **ip_address**:52372] AH00126: Invalid URI in request 'default.asp' 'GET 
default.asp HTTP/1.1'
Press [Enter] to continue:
 [Thu Jan 20 22:00:26.417195 2022] [core:error] [pid 9160:tid 140121982605056] 
[client **ip_address**:58960] AH00126: Invalid URI in request 'bin/sh' 'POST 
/cgi-bin/.%2e/.%2e/.%2e/.%2e/bin/sh HTTP/1.1'

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
[Resources]
Your disk is almost full: You could try to increase your instance’s storage.

Filesystem Size Used Avail Use% Mounted on /dev/sda1 9.8G 8.5G 783M 92% /

Please check your cloud provider’s documentation for more information.

[Php]
The following error appears in the
/opt/bitnami/php/var/log/php-fpm.log:

Press [Enter] to continue:
[20-Jan-2022 18:21:02] WARNING: [pool www] server reached max_children setting 
(5), consider raising it

This error usually indicates PHP script execution is slow due to busy server
resouces or buggy scripts. Please check the following guide to increase the
number of PHP-FPM child processes:

https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/

===== End of bndiagnostic tool output =====

Press [Enter] to continue:
The diagnostic bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
d9f87efc-557b-41d1-f44f-41989ee3ccb2
And paste it in your Bitnami Support ticket.

I ran the command sudo /opt/bitnami/bncert-tool to generate the certificate again and now it works.
Thanks a lot @davidg for your help .

Hi @agservice.its,

Happy to hear that :).

Regards

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.