We have been asked to import some plugins but get an error when trying to import them

Keywords: Moodle - Microsoft Azure - How to - Other
Description:
We have been asked to install the following into Moodle:

  1. Synergybase.zip must be placed in the theme/ folder
  2. Synergy.zip must be placed in the blocks/ folder
  3. Activitybookmarks.zip must be placed in the blocks/ folder
  4. Coursecatalogue.zip must be placed in the local/ folder.

When trying to import them through the site administration, we get this error?

Install plugin from ZIP file
Validating theme_synergybase ... Error
  [Error] Extracted file not found [{"file":"synergybase\/.git\/objects\/info\/"}] 
Installation aborted due to validation failure

None of us have any experience with Moodle or Linux operating systems .WE are a charity and are doing this totally blind without any experience or expertise.

Can anyone help?

Thanks
Stephen

Hi @stephen.clark,

Thank you for using Bitnami. First of all, we would like to get more information about your Moodle application and the process you are following to extract those files into the Moodle’s folders.

The Bitnami Support tool will gather all the information related with the deployment (logs, configuration, permissions, …). Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Regarding the process you are following to extract the files, could you please post the exact steps you are performing?

Thanks

Hi @jota

When I go to Site Administration -> Plugins -> Install Plugins; I drag the Zip file into the choose a file box, then select Themes from the plug in type. After clicking on Install plugin from the ZIP file, I get that error message.

Our version is 3.9.2 (Build 20200914).

I’ve ran the support tool and the code is: b57fc1dc-2037-b3b4-aad9-9b5928be6c8b

Let me know if you need more information from me.

Appreciate your help here :slight_smile:

Hi @stephen.clark,

I just launched the latest version of the Bitnami Moodle solution and install one theme/plugin without problems

image

I downloaded the plugin from here and selected a version compatible with the Moodle’s version I have (3.10.x). Please ensure the theme/plugin you are installing is compatible with the Moodle’s version you have and ask the theme’s developers in case you continue receiving the error. It seems Moodle can’t validate the installation.

Happy to help!


Was my answer helpful? Click on :heart:

Hi Jota,

Thanks for your support so far. We’ve been asked if we can try upgrading to build 3.9.4. (even though they say the minor version shouldn’t affect anything)

Are you able to advise on how to upgrade to build 3.9.4 - or do I need to start another post for that?

Thanks
Stephen

Do not worry, it’s related to the original question so I can continue helping you here.

First of all, I suggest you take a backup of the current instance to recover the data easily in case something goes wrong.

After that, you can follow this guide to upgrade the app to that new version. Please note that we do not know if some of your plugins will stop working due to they do not support that new version.

https://docs.bitnami.com/azure/apps/moodle/administration/upgrade/

Happy to help!


Was my answer helpful? Click on :heart: