W3-Total Cache Browser Caching Issue

Keywords: WordPress - Google Cloud Platform - Technical issue - Other
Description:
I have managed to install and fully setup W3-Total Cache plugin enabled all settings that I needed http/2 push and minification and other features are working but browser caching seems not to work.

I have edited to enable modules that are required
/opt/bitnami/apps/wordpress/htdocs/.htaccess

Restarted the apache

And the output of the .htaccess seems to be valid and properly edited by W3-Total cache plugin.

It should set the headers to 1 year expiration date but instead it does not set any headers whatsoever like they are totally ignored what seems to be the issue is beyond me at this point and I have spent hours reading forums but I could not troubleshoot the issue.

Any help would be appreciated,
This is my first post so please excuse any violations if I made any.

Thanks in advance,
Uros

Hello @kadza

As you can find in the Docs section below:
https://docs.bitnami.com/google/components/apache/#how-to-configure-htaccess-files

Bitnami stacks recollect all the htaccess information in a single file, /opt/bitnami/apps/wordpress/conf/htaccess.conf in your case and the AllowOverride option is set to None. Therefore, please add what you modified at /opt/bitnami/apps/wordpress/htdocs/.htaccess to that file and then, restart Apache.

Please let us know if that solves your issue.

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

Yeah my bad for not reading the docs thoroughly, it there fixed the
problem. Tho bit unpractical that for every change I would have to modify
file by hand I am okay with added security.

Hello @kadza

Great!!! I am glad that you were able to overcome the issue. I proceed to close this ticket as solved. If you have any other questions, please do not hesitate to open a new thread.

Best Regards,

Juan Ariza