VM: Empty people view for company

Start VM “eXo Platform 4.4.0-3 (64-bit)” and click on People for Company.
Result will be an empty view.

Tested with Google Chrome V62 and IE V11.

VM run on VMware Player 14 and ESXI.
Same result.

Any suggestion how to fix this issue?

Thanks in advance
Thomas

Hello @sap

I was able to reproduce the issue. Thanks for reporting it. This is the expected result:

This is the one obtained:

It seems it’s complaining about connecting to ElasticSearch (which is not included in the Stack). Maybe it’s a problem in the configuration. I opened a task to investigate and fix it asap. We will notify you about our progress.

Best Regards,

Juan Ariza

Hi Juan

Do you have a time estimation for the fix?

Thanks in advance

Best regards
Thomas

Hi @sap

I am afraid we can’t provide you any ETA for this fix. Please note our engineering team provides service for many different stacks, and we are working hard to improve the user experience on every one of them. Thanks in advance for your consideration and patience. We will notify you about our progress.

Best Regards,

Juan Ariza

1 Like

@jariza This is an issue with us too. The “People” page is blank and it stops us to roll the setup out to intended audience. This is basic functionality missing. Please take this up on priority.

On some investigation, the error on the page (thru Crome inspect) is:
ReferenceError: CKEDITOR is not defined

Please look at it on priority.

Hello @tech.nikoo

Thanks for the information. I will scale your concerns to see whether we can put this up on priority.

Best Regards,

Juan Ariza

Thanks @jariza for taking this up on priority.

A Bitnami image of collaboration web app that does not let people connect with each other is a basic functionality missing and therefore is not of production quality. The image should not have been released with this bug.

Please do communicate this to the right group and get this fixed. I am keen to use Bitnami image (I have used multiple other images) so following up closely :slight_smile:

Hi @tech.nikoo

We already identified the issue. ElasticSearch JAR is embedded in the ExoPlatform app but it seems we are not shipping in Tomcat some libraries that are needed in order to make this functionality to work.

Thanks in advance for your consideration and patience. We will notify you about our progress.

Best Regards,

Juan Ariza

1 Like

Perfect @jariza. Will wait for the fix to be available. If there is a workaround available for current images, please notify that as well.

Hello @tech.nikoo

Answering in the name of @jariza today.
There seems not to be an easy workaround for the current published images and we are sorry for it.
As of Christmas and New Year holidays this fix is experiencing delays to be shipped but it shouldn’t take much time until a fix is released.

Please, subscribe to releases of Bitnami Exoplatform installer at https://bitnami.com/stack/exo-platform-community (click on the “Follow” button)

Regards,
Jorge

@jariza @jorgemarin Please let us know if a release timeline has been set.

Hi all,

Sorry for the delay on this, we completely forgot to come back to you.

We already released a new revision of eXo Platform fixing this issue. Fixing current installations is pretty straightforward:

  • Open INSTALLDIR/apps/exoplatform/gatein/conf/exo.properties.

  • Remove the following line:

      exo.es.embedded.enabled=false
    

    And this one as well:

      exo.es.indexing.replica.number.default=0
    
  • Restart your services:

      INSTALLDIR/ctlscript.sh restart
    

Let us know if it worked for you.

Best regards,
Marcos

Perfect. Thanks @marcos

1 Like