Visual tab is not visible on Post editor

Keywords: WordPress - AWS - Technical issue - Other
bnsupport ID: 8e671a92-8783-79de-bd0f-cca706bb9215
Description:
On “Add New” page of “Posts” section, the editor usually displays two tabs: Visual and Text.

I’ve setup my env using Bitnami Wordpress AMI, then I’ve imported my wordpress project using the “All-in-One WP Migration” plugin.

The original project (run on a simple local Wordpress) displays correctly the two editors.
But the same project imported to the Bitnami stack does not work.

There is no error displayed on the browser console.
The tinymce file is accesible through the browser (…/wp-includes/js/tinymce/wp-tinymce.php

I’ve found a lot of possible causes/fixes when searching for this issue but nothing worked:

  • check / uncheck the “Disable the visual editor when writing” on profile
  • disable all plugins
  • install “TinyMCE Advanced” plugin
  • add “define(‘CONCATENATE_SCRIPTS’, false);” in “/opt/bitnami/apps/wordpress/htdocs/wp-config.php”

None of those did work.

My last guess is that there is some issue on the htaccess conf that I’ve added for caching.
Or permissions issue due to the bitnami AMI?

Does anyone ever encounter this issue and found a way to solve it?
Or at least can help me how to debug it?

Ok, after lot of struggling and resetting the whole stack, issue was just about the User-Agent that was rewritten by the CDN in front of the app.
If someone encoute rthe same issue, just add a custom behaviour for /wp-admin/* to pass all Headers and you should be good to go.

Hi @Nataneko,

I’m glad to hear you found the solution Thank you for sharing it :smile:


Please, click on :heart: if you think my answer was helpful

Yes thank you so much…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.