Virtual Machine - Shorten IP to DNS Name

Hi there, i have been accessing the phabricator url with ip address.
I have assigned it a dns name as such: MyProject
When, i tried accessing http://MyProject/
i got the following:
This request asked for “/” on host “Personalproject”, but no site is configured which can serve this request.

What should i configure in phabricator to allow me to access it using http://MyProject/

i have tried setting the ./bin/config set phabricator.base-uri http://MyProject/
I have the following: Usage ExceptionL Config option ‘.’ is invalid. The URI must contain a dot (‘http://example.com/’), like ‘http://example/’, not just bare name like ‘phabricator.base-uri’. Some web browsers will not set cookies on domains with no TLD.

Is there anyway, where we can configure apache so that when i access MyProject, apache will forward to the IP address of the phabricator instead?

Hi @AmazingTrans,

Is your Phabricator running in AWS? Probably this information below could help you


Phabricator requires that you access using the specific configured domain. This domain is the public IP for all cloud options except AWS cloud. For this cloud you should use the domain like ec2-aaa-bbb-ccc-ddd.compute-1.amazonaws.com. If you access using the IP you will see the following message:

So in order to access to your phabricator instance in AWS you need to go through the domain http://ec2-aaa-bbb-ccc-ddd.compute-1.amazonaws.com . If you want access using the IP address you can add it on the phabricator settings running the following command, replacing IPADDRESS:

$ sudo /opt/bitnami/apps/phabricator/htdocs/bin/config set phabricator.allowed-uris '["http://IPADDRESS"]'

Nope, i downloaded a Bitnami Phabricator VM and kept it in a internal server to service many people.

Hi @AmazingTrans,

Could tell me step by step what changes you have applied so I can try to reproduce the issue?

Hi @davidg,

All I have done is there is an ip address 192.168.2.10 , and it works.
But, in hyperV, we assign a DNSName to the machine, so whoever access for example: http://MyProject/
it will get forwarded to 192.168.2.10

Hi @AmazingTrans,

I think this guide could be useful in your case:
https://wiki.bitnami.com/Applications/Bitnami_Phabricator#How_to_change_the_default_hostname_of_the_application.3f

Could you let us know if it works for you?