Varnish cache serverError 503 Backend fetch failed

Keywords: Magento - AWS - Technical issue - Other
Description:
Hi , while opening our IP , we installed magneto we are getting this error

Error 503 Backend fetch failed
Backend fetch failed

Guru Meditation:
XID: 2785385

Varnish cache server

Kindly Provide a solution for the same.

Hi , just to add one more part , this error came after enabling the developer mode ,
has tried with few old articles , but none of them helped in fixing the issue. BUG: ERROR 503 after installing extensions from command line using composer ( This was the topic which report the same error .

[eduard](

If the magento is switched to the mode developer, you can see page error 503. My solution that helps me is as follows: in root give the following commands:

Copy

cd /opt/bitnami/apps/magento/htdocs
php bin/magento cache:enable
php bin/magento cache:clean
rm -rf var/cache/*
sudo /opt/bitnami/ctlscript.sh restart varnish

But the above solution is also not working now.
Please provide a Possible solution for the same
Thanks

Hi @coding247,

Please note that you need to use the Bitnami Magento CLI tool to not to break the Magento’s permissions configuration

https://docs.bitnami.com/aws/apps/magento/administration/using-magento-cli/

This video tutorial helps you reset the Magento’s permissions

https://www.youtube.com/watch?v=V3yeN-Wkd-Y

Note: If you are using a new version of the solution, the Magento’s files are inside the /opt/bitnami/magento directory

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.