Using wordpress throught AWS Lightsail for institutional web site which is unstable with several down times per day

Keywords: WordPress - AWS - Technical issue - Other
bnsupport ID: badc77f9-d940-a6e0-8a64-08836a8834b7
Description:
Using wordpress throught AWS Lightsail for institutional web site which is unstable with several down times per day with no message or error on browser just timeout. The solution is go to AWS Lightsail console and click on “reboot” button, wait for few minutes and the web site is back up again.

Our tool detected the following issues

? Apache: Found possible issues
✓ Connectivity: No issues found
✓ Resources: No issues found
✓ Mysql: No issues found
? Php: Found possible issues

[Apache]

Found recent Pagespeed related error messages in the Apache error log:

[Thu Jun 10 01:13:46.082237 2021] [pagespeed:error] [pid 1255:tid 139878737889024] [mod_pagespeed 1.13.35.2-0 @1255] PageSpeed Serf fetch failure rate extremely high; only 52 of 1695 recent fetches fully successful; is fetching working?

We suggest disabling pagespeed and check if that improves the behavior. Please check the following guide to disable Pagespeed:

https://docs.bitnami.com/general/apps/wordpress/administration/use-pagespeed/#disable-pagespeed

Found recent error or warning messages in the Apache error log.

[Thu Jun 10 01:13:02.879319 2021] [proxy_fcgi:error] [pid 1264:tid 139878838601472] (70007)The timeout specified has expired: [client 45.79.113.187:56519] AH01075: Error dispatching request to : (polling)
 [Thu Jun 10 01:13:10.177688 2021] [proxy_fcgi:error] [pid 1264:tid 139879283414784] (70007)The timeout specified has expired: [client 173.231.59.210:19780] AH01075: Error dispatching request to : (polling), referer: https://www.domrock.ai/
 [Thu Jun 10 01:14:48.633761 2021] [proxy_fcgi:error] [pid 1243:tid 139878805030656] (70007)The timeout specified has expired: [client 185.93.69.140:57039] AH01075: Error dispatching request to :25565: (polling)

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

[Php]

The following error appears in the /opt/bitnami/php/var/log/php-fpm.log:

[10-Jun-2021 01:03:43] WARNING: [pool www] server reached max_children setting (5), consider raising it

This error usually indicates PHP script execution is slow due to busy server resouces or buggy scripts. Please check the following guide to increase the number of PHP-FPM child processes:

https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/

I also suggest you check this guide to see if there is any bot/attacker requesting your site with malicious intentions

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/deny-connections-bots-apache/