Upgrading from 9.0.10 to 10.0.0.2

I have an old version of Bitnami Owncloud that i upgrade to 9.0.10, but when i try to migrate in a new bitnami owncloud server (latest version 10.0.0.2 i have errors in mysql, searching that is because the gap in version.

My question is, how can I transfer the thata from old server to newer one, o how can I upgrade this server?

I don’t know if upgrade is best option because the whole stack it’s older:
Server version: Apache/2.4.10 (Unix)
PHP Version 5.4.35
Server version: 5.5.40 MySQL Community Server (GPL)
Ubuntu 14.04.1 LTS
It’s Vmware VMDK old format

Thanks

You might want to read this first;

https://docs.bitnami.com/general/how-to/migrate-php-application/

Regards;
E\

Thnks for the Answer but that information is to copy a local installation to Cloud Install.

I need to upgrade the whole stack with newer, but when I try I have mysql errors because Incompatible versions (because I need to upgrade to last major version before jump)

The another think i know is if I download the restant versions to upgrading that to catch the last version. I don’t know another way. Maybe there are another option.

Exporting user credentias and data maybe?

Thnks

Hi @ratacorbo,

You can find the information you need in our documentation:

How To Upgrade The Bitnami OwnCloud Stack?

Best regards,
Carlos R. Hernández

Was my answer helpful? Click on :heart:

1 Like

Yes. I do it that but I think is not possible because the gap between the version that I have and the latest is too big and makes errors in the sql. may be i need to get version to catch the latest version

Hi,

Another option could be unpacking the new owncloud tarball over your old stack (please make sure you backup first):

  • Backup your stack
  • Unpack the new owncloud tarball /opt/bitnami/apps/owncloud/htdocs
  • Copy the old config.php to /opt/bitnami/apps/owncloud/htdocs
  • Execute the upgrade command
  • Execute this command: php occ upgrade

Hope it helps.

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

1 Like

I tried that downloading a new full stack from bitnami page and receive error.

I downloaded earlier version and i get to upgrade to 10 version. But I get some warning in integrity check but I think is because the plugins i’m investigating that.

Thanks for everything

Hi,

We are glad that you were able to fix the issue.

If you have any other question and you think we can help, please don’t hesitate to ask.

Best regards,
Silvio Fernández