Upgrade to Odoo 14

Hi everyone,

Odoo 14 is now available in bitnami.com. The different cloud marketplaces will be updated soon with this new version.

Enjoy! :slight_smile:

1 Like

@jota Great work to you and your team! Where are all bugs to be reported. Now that this thread is set to close a link for future viewers to bug reporting would be ideal.

@jota Thanks for the update. I tried to install on a f1-micro engine but it appears as disabled, does it mean I need to wait for Google Cloud Marketplace to show v14.0 in order to deploy in a small machine?

Hi @noviasco,
Yes, the image needs to appear in the Marketplace. I have checkec and google has updated the versions.
Could you check ?.

Hi @rafaelrios, you are right, they have updated it today. Those are great news and I was able to deploy it. Thanks a lot.

You can achieve this on a f1-micro.

To do so follow these instructions.

Within your GCP Compute Engine shell

cd /tmp
sudo apt update ; sudo apt upgrade -y
sudo apt install wget htop vim git curl
wget https://bitnami.com/redirect/to/1203824/bitnami-odoo-14.0.20201030-0-linux-x64-installer.run
sudo ./bitnami-odoo-14.0.20201030-0-linux-x64-installer.run 
chmod o+x bitnami-odoo-14.0.20201030-0-linux-x64-installer.run 
sudo ./bitnami-odoo-14.0.20201030-0-linux-x64-installer.run

Follow the guided install and be sure to set install directory to /opt/bitnami/

Post install you can get your certs and help from the helper-tool.

sudo /opt/bitnami/bnhelper-tool

This will get you an install just like the Bitnami apps installers!

1 Like

Thanks for sharing your solution!

Using the bitnami installer you can actually install the application on virtually every machine, but make sure that the minimum specs are met in order for it to run properly :slight_smile:

Appreciate it. I was able to install it.

One thing to note with this and the Odoo 13 bitnami*.sh installer for Odoo is that pagespeed errors occur right out of the box.. that is to say the shell install.

I thought it would have been solved in the v14 but still the issue remains. It seems isolated to instances we have over SSL. If we go through insecurely to the IP direct this goes away.

To be more specific the error occurs on Edit of Website pages not all the time but it is a common error and a repeated one where the Odoo Error page pop's and you need to clear up to (sometimes) 20+ pagespeed errors.

The general error is the common (or uncommon depending on how you look at it)

Pagespeed Error:
Pagespeed not defined.
https://yourdomain.com/yourpage#:1:1

@noviasco let me know if you run into this as well during Website/eCommerce page editing. If you do we can combine our findings and present them after documenting more.

Hi @sandoval.g,

The Bitnami Odoo solution requires at least 2GB of RAM to work properly. Using a f1-micro instance doesn't meet that requirement and you can find many different errors. We suggest you use a bigger instance, I'm sure those PageSpeed errors will disappear :slight_smile:

We are not using the micro instances. We never have due the nature of the animal we are dealing with (Odoo) and the min requirements to have the system running.

The micro instance was just the example we used for the installer, your installer to be specific. The page speed errors occur on +2gb instances also and everything mentioned in the previous reply is specific to +2gb instances on GCP.

It is good that you clarified this for additional viewers. Once again, we do not run on micro instances but the installer allows the installation for testing purposes.

@noviasco If you are testing on a GCP instance micro or similar I would still like to know if you run into this issue.

Thanks again to all for the kind responses attached to this thread.

Can you monitor the available memory in the instance to confirm that there is enough free memory for PageSpeed to work properly? If you still get errors, maybe there is a Odoo's plugin that does not work properly with PageSpeed and in that case, you will need to disable PageSpeed

https://docs.bitnami.com/google/apps/odoo/administration/use-pagespeed/#disable-pagespeed

Hi @sandoval.g,

Thanks for the information. It seems PageSpeed doesn’t work well in the Bitnami Odoo solution. I’m going to create an internal task to review the configuration and update the solution.

Thanks for reporting it.

Hi @jota,

Thanks for the follow up. Let us know if there is additional information we can provide on our end to help you on your end.

Take care.

Thanks for your help! We will come back to the thread in case we need further information :slightly_smiling_face:

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @sandoval.g, sorry for the late reply. I haven’t ran into those errors yet (perhaps because my deployment is not focused on web app) but the good thing is Bitnami team is already checking on the page speed compatibility.

@noviasco

No worries, it is specific to the web applications. Website and eCommerce anything that is public facing. These errors do not occur on the backend at all. At least not to our knowledge.

@jota

I have had success triggering the PageSpeed errors 15/15 times. It seems related to the view as well. Scrolling to the bottom of the page and ending the page also triggers the PageSpeed errors and initiates an error for every “Key” typed on keyboard.

Regardless of the position or block. Any attempt to type or use keyboard commands triggers this error. It becomes extremely apparent when scrolling through and down an entire page.

Hi @sandoval.g,

Thanks for the updated info. In the meantime, we recommend you to disable PageSpeed as Jota mentioned in a previous post so you avoid getting these errors until we found a fix.

Apart from that, I also think it is a good idea to ask in the Odoo forums just in case they are aware of any issue with PageSpeed

https://www.odoo.com/forum/help-1

@gongomgra

Not a problem, this is dev environment we are using to add in these notes. Essentially and consistently finding ways to break or trigger this particular issue.

PageSpeed has been disabled on any production enviro’s since Ov13. The Odoo forums also suffer quite a bit from this PageSpeed issue and it seems more stack related than Odoo related in our findings.

The Bitnami staff is likely aware of the forum’s (Odoo Help - Forum) mixed concerns with PageSpeed; however, if you would like we can compile a list of forum links with similar issues to ensure this information is available in these community forum’s as well as those on Odoo.

If not just send a quick note, we do not want to overload the information either.

Hi Jota,

I have finally had sometime to look at this again. Pagespeed errors continue to occur. The current instance has roughly 2.3 gb of FREE mem available 4GB. The instance is not the issue with Pagespeed at least not the way you describe it 2+ GB instances eliminate Pagespeed errors is a misassumption.

In fact this seems highly tied to key commands when editing within the Website editor specifically. This is not normal, Pagespeed flags on almost all CTRL+(key combo) to copy/paste, create a link etc.

Odoo plugin’s are only the base plugin’s at this point. CRM, Website, Sales, Invoicing were the ones installed.

These are not third party so the assumption of the instance and memory being directly tied to Pagespeed is not correct.

https://domain.com/?#scrollTop=0:642
Traceback:
ReferenceError: pagespeed is not defined
at HTMLImageElement.onload (https://domain.com/?#scrollTop=0:642:227)

This is the last error and I can have it reoccur whenever I’d like simply by using Key commands within the Live editor to start. Not just CTRL, this is also happening with the “undo button” and various other controlled commands.