I'm glad you managed to update both Frappe and ERPNext. For the messages you are getting, you can run the commands below in order to install the required version of the mentioned packages
pip install GitPython==2.1.11 six==1.12.0
sudo /opt/bitnami/ctlscript.sh restart
I did it myself and it looks like the packages are already installed, so I think it is fine
$ pip install GitPython==2.1.11 six==1.12.0
Requirement already satisfied: GitPython==2.1.11 in /opt/bitnami/apps/erpnext/htdocs/venv/lib/python3.7/site-packages (2.1.11)
Requirement already satisfied: six==1.12.0 in /opt/bitnami/apps/erpnext/htdocs/venv/lib/python3.7/site-packages (1.12.0)
Requirement already satisfied: gitdb2>=2.0.0 in /opt/bitnami/apps/erpnext/htdocs/venv/lib/python3.7/site-packages (from GitPython==2.1.
Requirement already satisfied: smmap2>=2.0.0 in /opt/bitnami/apps/erpnext/htdocs/venv/lib/python3.7/site-packages (from gitdb2>=2.0.0->
Requirement already satisfied: smmap>=3.0.1 in /opt/bitnami/apps/erpnext/htdocs/venv/lib/python3.7/site-packages (from smmap2>=2.0.0->g
I also noticed I sent you a wrong screenshot. Here is the screenshot with the correct versions in use after running the upgrade procedure
Can you confirm that you get a similar output when trying to install the pip packages so we can consider this thread as solved?