Upgrade Bitnami Google Cloud Moodle v2.9 to v3.2 then to v3.7,

Keywords: Moodle - Google Cloud Platform - How to - Upgrade
Description:

  1. I try to upgrade google cloud moodle directly from v2.9 to v3.7, but after upgrade and try to go to the application, it says i need to upgrade to v3.2 first. Is there any way around this?

  2. To upgrade moodle to v3.2.9 first, which version of Stack should I use? Is 3.1.3-0 correct:

wget https://downloads.bitnami.com/files/stacks/moodle/3.1.3-0/bitnami-moodle-3.1.3-0-linux-x64-installer.run

Thanks,
Charles Lim

One more question…Base on this discussion How to Update PHP Version so Moodle Upgrade Works, it run this command:

sudo tar -xzvf moodle-3.2.1.tgz -C /opt/bitnami/apps/moodle/htdocs/
Which only unzip 1 folder and a file into htdocs, namely, #moodle# and #config.php.
Is this correct? Don’t quite understand; the newly unzipped moodle is now in /opt/bitnami/apps/moodle/htdocs/moodle, is this correct?

Hi @charlesyclim,

Instead of upgrading Moodle, I recommend launching the latest Bitnami Moodle and migrating the Moodle data to it.


Please, click on :heart: if you think my answer was helpful

Hi Michiel,
My current bitnmi gc moodle ver is 2.9. I cannot upgrade to ver 3.7 directly, moodle will throw error saying i must upgrade to 3.2 first (https://docs.moodle.org/en/Upgrading). So i have no choice but to do the upgrade to 3.2 manually first. Then from 3.2 to 3.7, i will create the latest binami moodle.

Actually, today i just managed to upgrade to 3.2 already, using Bitnami Moodle stack 3.2.3 and Moodle v3.2.1.

However, i have some uncertainties regarding updating of the folders in /mod. The new moodle have folders in /mod, my existing moodle (lets call it old moodle) also have folders in /mod. Should i :
(1) remove all the new folders and have only the old folders in /mod; or
(2) transfer only old folders that do not exist in the new folders?

I also have similar question for the folders for /theme.

Hi @charlesyclim,

To upgrade Moodle the steps in the following guide should work:

https://docs.bitnami.com/general/apps/moodle/administration/upgrade/


Please, click on :heart: if you think my answer was helpful

Thanks. Actually, i have already read them. Will let u know if anymore
issue.

Another question. I have created a new Bitnami google cloud instance
moodle3.7, which i will transfer from my current 2.9 instance, which have a
ssl.

The question is, how i move the ssl from the 2.9 to the 3.7 instance? I
know google cloud allow me to use the fixed ip in 2.9 in another instance.
But the certificate Signing Request (CSR) was originally created in the 2.9
instance. Any problem if i use the same ssl in the 3.7 instance?

Thanks.

Hi @charlesyclim,

That should not be a problem, if you move the private and the public key to your new machine.


Please, click on :heart: if you think my answer was helpful

Thanks. When I execute command: sudo apt-get install sendmail
below are the output, which has warning saying 3 db sources were not found.
What could be the problem?

Please edit /etc/hosts.allow and check the rules location tomake sure your
security measures have not been overridden -it is common to move the
sendmail:all line to the end ofthe file, so your more selective rules
take precedence.Checking {sendmail,submit}.mc and related databases…Reading
configuration from /etc/mail/sendmail.conf.Validating configuration.Creating
/etc/mail/databases…Reading configuration from
/etc/mail/sendmail.conf.Validating
configuration.Creating /etc/mail/databases…Reading configuration from
/etc/mail/sendmail.conf.Validating configuration.Creating
/etc/mail/Makefile…Reading configuration from
/etc/mail/sendmail.conf.Validating
configuration.Writing configuration to /etc/mail/sendmail.conf.Writing
/etc/cron.d/sendmail.Disabling HOST statistics
file(/var/lib/sendmail/host_status).Creating /etc/mail/sendmail.cf…Creating
/etc/mail/submit.cf…Informational: confCR_FILE file empty:
/etc/mail/relay-domainsWarning: confCT_FILE source file not found:
/etc/mail/trusted-users it was createdInformational: confCT_FILE file
empty: /etc/mail/trusted-usersWarning: confCW_FILE source file not found:
/etc/mail/local-host-names it was createdWarning: access_db source file not
found: /etc/mail/access it was createdUpdating /etc/mail/access…Linking
/etc/aliases to /etc/mail/aliasesInformational: ALIAS_FILE file empty:
/etc/mail/aliasesUpdating /etc/mail/aliases…/etc/mail/aliases: 0 aliases,
longest 0 bytes, 0 bytes total Warning: 3 database(s) sources were not
found, (but were created) please investigate.Setting up sensible-mda
(8.15.2-8) …Setting up sendmail (8.15.2-8) …Processing triggers for
systemd (232-25+deb9u11) …

Hi @charlesyclim,

Can you check if it’s installed?

sudo /usr/sbin/sendmail -q

Please, click on :heart: if you think my answer was helpful

I now want to setup the email using SendGrid.
I tried using a newly installed Bitnami Google Moodle instance, and I setup using the scheduling instructions from:
https://docs.bitnami.com/google/apps/moodle/configuration/install-cron/
and the SendGrid settings using:
https://docs.bitnami.com/virtual-machine/faq/configuration/use-external-smtp/
And it was able to send out Email notifications when I create forum post.

However, when i setup in another site I upgraded from v2.9 to v3.7, it didn’t work. What could be the issue?
The settings are all the same. The only different I can think of is I ran the command: sudo apt-get install sendmail
in the upgraded version. With sendgrid setup i do not need to install this sendmail right? Do i need to uninstall it? How do i uninstall it?

Hi @charlesyclim,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please download and execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code outputted by the tool in your reply.

Regards,
Michiel

Thank you. Below is the code:
f7128474-71c9-bd0f-8720-aa7e2d43a594

Hi @charlesyclim,

My apologies for not giving you the right information. The bnsupport tool has an SMTP checking tool which should be specifically enabled in the command line to run.

sudo /opt/bitnami/bnsupport-tool --runSMTPTool 1 

It will ask you for your SMTP hostname, port, username and password.

SMTP host: smtp.sendgrid.net
SMTP port: 25 
SMTP username: SendGrid account username
SMTP password: SendGrid account password

Could you please run the bnsupport tool again with these settings and send me the output code?


Please, click on :heart: if you think my answer was helpful

Attached are the new code.

25eddf87-68d1-6db7-c71d-e330f7dc93ee
But realize the log say dont have permission…
Actually i have used Moodle Plugin: email Test, and it work fine. Below is
the output. I also did received the email in the target mailbox.
However, when i run at Moodle/Site Administrator/Server/Tasks/Schedule Taks
and click the Run Now button for “Forum mailings and maintenance jobs”, it
show the error:
========================= START of Schedule Task ======================
Forum mailings and maintenance jobs

Execute scheduled task: Forum mailings and maintenance jobs
(mod_forum\task\cron_task)
Removing old digest records from 7 days ago.
Removed all old digest records.
Fetching unmailed posts.
Done
Processing post information
Processed 15 posts
Filling caches
Filling course cache
Done
Filling forum cache
Done
Filling discussion cache
Done
Filling user subscription cache
Done
Filling digest cache
Done
All caches filled
Queueing user tasks.
Processing 432 users
Queued 0 digests and 1 messages for 6077
Queued 0 digests and 1 messages for 6050
Queued 0 digests and 1 messages for 6049
Queued 0 digests and 1 messages for 6051
Queued 0 digests and 1 messages for 6122
Queued 0 digests and 1 messages for 6055
Queued 0 digests and 1 messages for 6052
Queued 0 digests and 1 messages for 6072
Queued 0 digests and 1 messages for 6075
… used 134 dbqueries
… used 0.21243691444397 seconds
Scheduled task failed: Forum mailings and maintenance jobs
(mod_forum\task\cron_task),Suspended account

Back to scheduled tasks
https://lms.bcaa.edu.sg/admin/tool/task/scheduledtasks.php
===================== END of log for Schedule Taks

Hi @charlesyclim,

I’m forwarding the issue to another team, they will update the topic or request additional information.

Regards,
Michiel

Hi, @charlesyclim.

This seems to be an issue upstream: https://tracker.moodle.org/browse/MDL-65655

As you can see, a user is reporting the same issue after upgrading to v3.7. Apparently, there’s already a fix for it that will land on Moodle 3.7.1, so please, wait until 3.7.1 is released and let’s see if the issue is gone.

Regards,
Alejandro

Thanks Alejandro. For a release, how do you know if a particular issue
resolution is included?

Hi, @charlesyclim.

You can see it in the issue tracker, on the right column:

Seems like 3.7.1 has just been released. I see at
https://download.moodle.org/releases/latest/

Just to confirm how i should patch:

  1. move /opt/bitnami/apps/moodle/htdocs to …/moodle/htdocs.backup
  2. download the latest moodle tgz and unzip it.
  3. create a new /opt/bitnami/apps/moodle/htdocs folder, and move all the
    folders under moodle(from the latest moodle unzipped folder in 2) , to it.
  4. copy the …/htdocs. backup/config.php to …/htdocs/config.php
  5. copy over all the folders under the following from backup:
    htdocs/mod
    htdocs/theme
    htdocs/local
    htdocs/report
    that is in the backup folder but not in the new moodle folders.
    Is the above steps correct?

Hi, @charlesyclim.

Here you can find a guide to upgrade Moodle: Upgrade Moodle.

Regards,
Alejandro