Upgrade 4.3 to 4.4

Google Cloud Bitnami exo 4.3 CE

Any guide on how to upgrade to exo 4.4 CE?

Thanks & Regards.

Hi @taidaniel,

Thank you for using Bitnami. Could you please check the official documentation of eXo that explains the process about how to upgrade the application?

https://www.exoplatform.com/docs/public/index.jsp?topic=%2FPLF44%2FPLFAdminGuide.Upgrade.Process.html

Please note that you’ll need to follow the “For Native Installer” section.

Before starting the upgrade process, could you please create a backup of the installation directory to recover it easily in case you run into any issue during the upgrade process?

https://docs.bitnami.com/google/apps/exo-platform-community/#backup

Regards,
Jota

Hi,
Thank you, I’ve managed to upgrade to 4.4 following the instructions.

I am able to access the portal login page via www.urlname.com but it shows the error attached after login.

Before the upgrade, I could access via the urlname.com without issues.

If I access via port 8080 it works fine. I am not sure which file to amend to enable access via port 80. Any suggestions?


I manage to solve the above by adding “Timeout 600” and “ProxyTimeout 600” to the httpd.conf file. Please do advise if there is a better way to do this.

I’m trying to configure for HTTPS access. Followed the instructions, added the necessary as attached into the bitnami.conf file. Please do advise what I am doing wrong.

Attached error.log & platform.log also

Hi @taidaniel,

Could you please let us know the specifications of the running instance? Are all the services inside that instance running?

sudo /opt/bitnami/ctlscript.sh status

Could you please share more content of the log files you’ve shared? You can also send them to my Bitnami account jota@bitnami.com.

Regards,
Jota

Hi, I apologize. It was the port not opened. I must have overlook this. All is working well now.

Thanks for your help.

Hi @taidaniel,

Thank you for letting us know it. We were checking the log files you shared with me but this is good news!

Enjoy the application :slight_smile:

Jota

Hi,

As per your request… All tomcat, postgres & apache is running as normal.