Update Issue bitnami

Keywords: Mautic - Google Cloud Platform - Technical issue - Upgrade
bnsupport ID: fac0f020-d6da-dcbc-a176-709fa4710052
Description:
Hi, I was tried to Update my Nautic versión using this Commands
cd /opt/bitnami/apps/mautic/htdocs
root@copy-mautic:/opt/bitnami/apps/mautic/htdocs# # sudo su daemon -s /bin/bash -c " app/console "
root@copy-mautic:/opt/bitnami/apps/mautic/htdocs# sudo su daemon -s /bin/bash -c “/opt/bitnami/php/bin/php app/console mautic:update:find”
Then I got the next Message:
La versión 2.16.5 de Mautic está disponible para descargar. Para más información, vaya a https://www.mautic.org/blog/community/security-release-all-versions-mautic-prior-2-16-5-and-3-2-3, por favor.
Para actualizar, puede ejecutar ‘php app/console mautic:update:apply’ desde la línea de comando.
When I wrote
php app/console mautic:update:apply
¿Estás seguro de que quieres actualizar la última versión de Mautic? yes
Step 6 [------>---------------------] mautic.core.command.update.step.update_languages
I receive this Error Message:
[Symfony\Component\Debug\Exception\ContextErrorException Catchable Fatal Error: Argument 1 passed to Mautic\CoreBundle\Helper\LanguageHelper::__construct() must be an instance of Mautic\CoreBundle\Helper\PathsHelper, instance of autic\CoreBundle\Factory\MauticFactory given, called in /opt/bitnami/apps/mautic/htdocs/app/cache/prod/appProdProjectContainer.php on line 10408 and defined

Also, I tried using the command

/opt/bitnami/php/bin/php app/console mautic:update:apply
¿Estás seguro de que quieres actualizar la última versión de Mautic? yes
Step 1 [->--------------------------] Actualizando información…
You can only upgrade to Mautic 3 by running ‘php upgrade_v3.php’ instead of this command.
root@copy-mautic:/opt/bitnami/apps/mautic/htdocs# php upgrade_v3.php
Welcome to the Mautic 3 upgrade script! Before we start, we’ll run some pre-upgrade checks to make sure your system is
compatible.
IMPORTANT: you will need to update your cron jobs from app/console/* to bin/console/* after the upgrade. You can alrea
dy change them now if you want.
Please type ‘yes’ if you’re ready to start: yes
Thank you, continuing…
===== STARTING MAUTIC 3 UPGRADE AT 2021-04-08 09:06:04… =====
Installed Mautic version: 2.16.5
PHP version: 5.6.24
OS: Linux
Upgrade type: CLI
Doing pre-upgrade checks…
Warning: Using a password on the command line interface can be insecure.
One or more errors occurred during pre-upgrade checks:

  • Your server does not meet the minimum PHP requirements. Mautic requires PHP version 7.2.21 while your server has 5.6
    .24. Please contact your host to update your PHP installation.
  • Your MySQL/MariaDB version is not supported. You need at least MySQL 5.7.14 or MariaDB 10.2 in order to run Mautic 3

I don’t know how to update My PHP versión, or how can I Update My Mautic Bitnami

Hello @nataly.fonseca,

Please note that Bitnami Stacks are completely self-contained and run independently of the rest of the software or libraries installed on your system. For that reason, it is not possible to upgrade one component of the stack (in this case PHP).

You need to upgrade de full stack and then restore your files. You should launch a new cloud image with the latest version, and then migrate your data there.

With the steps above, you would have Mautic with the latest PHP 73 version.

I hope it helps