Uninstall SSL ncert

Keywords: WordPress - AWS - Technical issue - Secure Connections (SSL/HTTPS)

bnsupport ID: f57e3b59-6875-4301-6c75-bd6ae44955ee

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
? Php: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/administration/use-pagespeed/#disable-pagespeed
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/

bndiagnostic failure reason: The tool could not find any issue

Description:
Hello, I recently installed bitnami ssl, but I would like to go with the amazon one, to be able to enable the cdn.

I tried to use different commands I found here but doesn’t work. I tried to follow documentation but I didn’t figure out how to make it.

Thanks

Hi @gabimolocea,

I can see you generated Let’s Encrypt certificates in the past but you didn’t configure the auto-renew process. In this case, you just need to upload the AWS certificates to the /opt/bitnami/apache2/conf/ folder and update the SSLCertificateFile and SSLCertificateKeyFile lines in the /opt/bitnami/apache2/conf/bitnami/bitnami.conf file.

SSLCertificateFile "/opt/bitnami/apache2/conf/YOUR_NEW_CERTIFICATE.crt"
SSLCertificateKeyFile "/opt/bitnami/apache2/conf/YOUR_NEW_CERTIFICATE.key"

Note: You can replace the server.crt and server.key files there.

Once you do so, please restart Apache.

sudo /opt/bitnami/ctlscript.sh restart apache

You can find more information here:

https://docs.bitnami.com/aws/apps/wordpress/administration/enable-https-ssl-apache/

Happy to help!


Was my answer helpful? Click on :heart:

Hi,
I am not able to download the ssl certificates… I added the CNAMES but they are in pending and not getting validated. I suppose this happens because of the installed ntcert that exists already.

Hi @gabimolocea,

The AWS Lightsail team should provide you more information about why the certificate is not being validated. Once you have more info, do not hesitate to contact us in case you need to make any change in the configuration.

Thanks

I figure out what was the mistake… now the certificate looks to be validated, I added the CNAMEs, but on the website it doesn’t point to cloudstorage

Hi @gabimolocea,

That’s a separate question. However, we have a guide in our documentation that explains how to configure WordPress to work with S3, did you check it?

https://docs.bitnami.com/aws/apps/wordpress/configuration/wordpress-aws-s3/

If you have any questions regarding the plugin or its configuration, please ask the plugin’s developer to know more about it.

Happy to help!


Was my answer helpful? Click on :heart: