Unable to use key file "C:\..." (not a private key) Putty

Hello,

Whenever I try to SSH with putty into my bitnami ec2 instance with the key file I downloaded from bitnami manager I get the following alert: Unable to use key file "C:\..." (not a private key)

Tried downloading the file in both ppk and also tried to convert the pem file but it also states that it must be a private key.

Any help would be much appreciated tried google and cant find any solution.

Regards,

Felix

Hello Felix ,

You need to download puttygen and covert the key , then download a putty(ssh client).You can get the access
4 Likes

Hello I have already tried to use putty to convert the pem file but it also stated that it cannot because its not a private key.

Hello Felix,

                         PuTTY does not natively support the private key format generated. Fortunately, PuTTY has a tool called PuTTYgen, which can convert keys to the required PuTTY format.

convert your private key Start PuTTYgen (e.g., from the Start menu, click All Programs > PuTTY > PuTTYgen). Click Load and browse to the location of the private key file that you want to convert (keyname.pem). By default, PuTTYgen displays only files with extension .ppk; you'll need to change that to display files of all types in order to see your .pem key file. The private key file must end with a newline character or PuTTYgen cannot load it correctly.

Select your .pem key file and click Open. PuTTYgen displays a message.

When you click OK, PuTTYgen displays a dialog box with information about the key you loaded, such as the public key and the fingerprint. Click Save private key to save the key in PuTTY's format.

use puttygen to convert the key

I have used puttygen it also stated the same warning.

I have used puttygen with my pem file which was downloaded from bitnami manager and it stated a warning:

Couldn't load private key (not a private key)

You can download from putty website , puuty gen

Open putty gen application , click on "load " button. A pop up window open , and go to the destination having .ppk file Select the .ppk file and click on "Generate button".

You will get a loader in green color , and below that there is a blank space , just move the mouse over it . Until the green color fills up,

Then click on save private key .

Creating my own key from puttygen creates a warning stating: Disconnected: No supported authentication methods available (server sent: publickey)

ok , you where able to create private key,

Now follow the putty documentation ,

http://wiki.bitnami.com/BitNami_Cloud_Hosting/Servers/SSH#How_to_connect_to_my_server

try for two to three times , see if you have missed any step.

I don't think you understand my problem mate.

The key that's being downloaded from bitnami is a public key and not private key. I cant use it all.

Okay solved my problem.

What I was doing wrong was downloading the key from bitnami Clouds: Manager> Download key... and not from bitnami Server: Server>Manager>Connect...

All good now :)

5 Likes

good to know about that :) .

I am very glad to hear that.

Regards.