Unable to use Bitnami WordPress after Mac OS 11 Big Sur update

Keywords: WordPress - OS X - Technical issue - Other
Description:
Hello! Since installing the Mac OS 11 Big Sur update, I’ve been receiving the following error when trying to launch WordPress locally: “cannot calculate MAC address: hv_vm_create unknown error -85377023”

I’ve attempted to go through the steps that others have suggested in other conversation threads, but for some reason when I attempted to complete the step “Download the new hyperkit binary,” the download and text would not open in the correct format.

Any help would be appreciated!

Hi @argrender,

You can follow these steps to update the hyperkit binary.

  • Run these commands in the terminal:
cd ~/
sudo rm -rf .bitnami/stackman/helpers/hyperkit

Then, download the latest version of the solution from bitnami.com and execute it.

https://bitnami.com/stack/wordpress/installer

Happy to help!


Was my answer helpful? Click on :heart:

1 Like

That worked! Thank you so much.

One last question: Is there anything I need to do now to get the old link to my local WordPress website to load? I’m having trouble with that now in my browser and not sure why. I copied a backup file of the original data, and I believe I followed those steps correctly, but perhaps I missed a step integrating that original data.

Thanks again for your help!

Hello @argrender,

Are you referring to the IP address you were previously using? The launcher should output the used IP once you start the Application, but it may not be the same used previously.

Regards,
Francisco de Paz

1 Like

Hi, @fdepaz, thank you for your response.

I hope I’m understanding you correctly. When I try to use the wp-admin link/IP address I had previously saved to edit my website locally, I am now unable to log in. I see that after updating the WordPress stack, the last digit of the IP address has changed, so I tried replacing the IP address in the wp-admin link to the new IP address. But then I receive an error message (screenshot included). Do you know what the problem is with my log in?

Thank you very much!

Hello @argrender,

Have you started your database (mariadb/mysql) services? If it can be started, there may be an issue with the database. We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Regards,
Francisco de Paz

Thank you, @fdepaz. When I try to select the WordPress app in the Support Tool, I’m unable to do so. See below.

I also tried copying the pathname of the WordPress app in Applications and using that to continue, but I received an error message saying that “The path does not seem to contain a valid Bitnami installation.”

Any idea what the issue is? Thanks, and apologies for all the back and forth. I’m definitely a novice with all of this!

Hello @argrender

This may be caused by some missing files or folders in your Wordpress installation, which could be related to the initial changes required to update the hyperkit binary. Did you use the latest version of our OS X installer when reinstalling Wordpress after removing ~/bitnami/stackman/helpers/hyperkit?

Regards,
Francisco de Paz

1 Like

Yes, I believe so. I downloaded WordPress once again using this link, which I think has the latest version: https://bitnami.com/stack/wordpress/installer

Now I have two versions saved to my machine. See here:

@fdepaz Also, when I launch the WordPress 2 app, I receive the following message. I’m not sure if this is helpful:

@fdepaz Lastly (and again, I’m not sure if this is helpful), here is a screenshot from my Finder. In the “WordPress1” folder, I have a backup of my website saved. I think this backup included the same data that is saved in the “WordPress original” folder.

Thank you.

Hello @argrender,

Let’s go back for a moment, when getting the Error establishing a database connection error, could you access de instance terminal and run the following command:

sudo /opt/bitnami/ctlscript.sh status

You are getting the won't be updated error because one of your instances was running. Seeing as you already have backups of your Wordpress data (make sure you followed our guide), an option would be to make a backup of your database data before uninstalling your 2 Wordpress instances and reinstalling Wordpress from scratch.

Regards,
Francisco de Paz

1 Like

Thanks! I’ll give this a try.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.