Unable to Update wp-config.php URL in WordPress

Keywords: WordPress - Google Cloud Platform - Technical issue - Connectivity (SSH/FTP)

bnsupport ID: 7bf982d5-212d-b7cc-9007-597b758c954d

bndiagnostic output:

? Wordpress: Found possible issues
? Resources: Found possible issues

bndiagnostic failure reason: The documentation did not make any significant change

Description:
Hello,

I tried to update my WordPress wp-config.php file by pasting the following code

sudo nano /opt/bitnami/apps/wordpress/htdocs/wp-config.php

But it showed the error

[Directory ‘/opt/bitnami/apps/wordpress/htdocs’ does not exit]

I read up some solutions in the community with these links

  1. https://docs.bitnami.com/google/faq/get-started/understand-upcoming-changes/
  2. https://docs.bitnami.com/google/apps/wordpress/administration/understand-file-permissions/

But they didn’t help at all.

What is the new path so I can update the wp-config.php file?

Thank you.

Hi @taiwodare,

Thanks for using Bitnami. The new path installation for WordPress application is /opt/bitnami/wordpress, and the config file is at /opt/bitnami/wordpress/wp-config.php.

Apart from the above, the bnsupport tool returned some errors in your server. We recommend you to check them. I’m also sharing the results with you here.

✓ Php: No issues found
✓ Apache: No issues found
✓ Connectivity: No issues found
✓ Mariadb: No issues found
? Wordpress: Found possible issues
? Resources: Found possible issues

[Wordpress]

Found recent WordPress plugin related error messages in the Apache error log.

[Thu Jul 29 16:39:00.013545 2021] [proxy_fcgi:error] [pid 3662:tid 140250110179072] [client **ip_address**:30048] AH01071: Got error 'PHP message: PHP Notice:  Unknown: file created in the system's temporary directory in Unknown on line 0', referer: https://kurtisadigba.com/wp-admin/plugin-install.php

Please check the following guide to deactivate plugins:

https://developer.wordpress.org/cli/commands/plugin/deactivate/

[Resources]

Your instance has little available RAM memory.

              total        used        free      shared  buff/cache   available
Mem:            585         384          76          42         124          72
Swap:          1658          85        1573

You could try to increase your instance’s memory. Please check your cloud provider’s documentation for more information.

2 Likes

Hello @gongomgra,

Thank you for your help, it worked!

Glad to see you were able to solve your issue! We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart: