Unable to open Bitnami Wordpess Multisite

Keywords: WordPress Multisite - OS X - Technical issue - Connectivity (SSH/FTP)
bnsupport ID: TOOL DOES NOT WORK - CANNOT FIND /OPT
Description:
All services appear to run correctly, turning green. Go to application, opens web browser window and says "Safari cant find the server ‘…’

I just tried restarting the pc and opening again and received a message stating - stack: another instance seems to be running PID 5576

NOTE: I have no other servers running in the background in any other tabs

From Google Chrome - This site cannot be reached – DNS_PROBE_FINISHED_NXDOMAIN

Hi @toms16590

Thanks for using Bitnami WordPress Multisite!

The xip.io domain seems down, can you follow this guide to update the application to use the nip.io domain?

https://docs.bitnami.com/installer/apps/wordpress-multisite/configuration/configure-wordpress-multisite/#configure-the-domain-for-the-wordpress-multisite-main-blog

You will need to run these commands

cd /opt/bitnami/apps/wordpress
sudo ./bnconfig --machine_hostname MACHINE_IP_ADDRESS.nip.io

In order to run the commands, please open the application dashboard and select Open Terminal.

18ec968be04b20d1727c08c9301e6216f7a007ce

Note that you have to substitute MACHINE_IP_ADDRESS in the command above by the IP Address shown in your application dashboard (highlighted in purple in the picture)

Could you please try that and report back?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

1 Like

Hi there,

This did not seem to fix the problem.

First of all, Bitnami WordPress Multisite did not open the terminal window fully. The icon popped up with a black dot under so I clicked on it to open the window.

Entering in the first line of code I received the response:
cd: no such file or directory: /opt/bitnami/apps/wordpress

I tried mounting the Bitnami Wordpress Multisite to find the wordpress file and jump straight into it, then ran the code you suggested to which the response was:
sudo: ./bnconfig: command not found

Thank you for your help, is much appreciated!
Tom

Hi again!

First of all, Bitnami WordPress Multisite did not open the terminal window fully. The icon popped up with a black dot under so I clicked on it to open the window.

Could you please provide a screenshot of the faulty window?

cd: no such file or directory: /opt/bitnami/apps/wordpress

sudo: ./bnconfig: command not found

This is most likely related to executing the commands from outside the terminal opened by the application dashboard. The screenshot (or an error message, if any) should help us identify what is happening.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

When I click the terminal button, this is what appears in the docks, nothing opens up on the screen

If the terminal does not pop up automatically, could you please click the icon in the dock to bring the window to the front?

By clicking the terminal icon in the dock you should be able to see a window like this one:

Screenshot 2021-05-06 at 11.39.09

That is the right place to execute the aforementioned commands.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

That window does not appear, it just opens a regular terminal window

That window does not appear, it just opens a regular terminal window

What happens if you close the regular terminal application and click on Open Terminal again? Are you prompted with a dialog requesting permissions?

Please, quit the application completely by using the menu (do not just close the window).

Screenshot 2021-05-06 at 12.16.37

Can you please check the following section in your System Preferences application?

Do you happen to have a message saying that the opening of an application was blocked?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Completely quitting the regular terminal and attempting to open using Bitnami does not work, with no prompts or dialogue requests.

System preferences are all the same.

No messages saying the application is blocked

Hi Jose,

Have fixed the issue with Bitnami terminal -

Systems preferences - Security and Privacy - Privacy - Automation - bash (turn on) & sh (turn on)

This has resolved the issue for opening Bitnami Wordpress Multisite, I can now follow your guide in changing the individual IP Addresses.

Thank you very much for your help!

Tom

So glad to see you were able to solve the issue! Sometimes the OS is just tricky with those things :slightly_smiling_face:

We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart: