Unable to install apache as a service for windows with name wordpressApache

“Unable to install apache as a service for windows with name wordpressApache” is the error I get upon installing a Wordpress stack, from this link - https://bitnami.com/stack/wordpress/installer

I’ve tried setting the ports to 81 and 444 (80 and 443 were taken, by Skype I believe), still didn’t work. I’ve tried restarting my computer, running the installer as admin, checking for errors (only log was install, no error logs), etc.

Windows 10
Intel I7-4750HQ
Nothing installed that should conflict, to my knowledge. I do have Vagrant installed, as well as Virtual Box, but I’m not seeing any conflict.

Any ideas?

Hello @gemfruit,

It might be your antivirus program. Could you please check the following post from our wiki?

https://wiki.bitnami.com/Native_Installers_Quick_Start_Guide/Antivirus

If after adding a firewall rule or temporary disable your antivirus the issue still persists you could send the installation log to my mail tomas [at] bitnami [dot] com. You can find that file under your temporal folder. It is a file called bitrock_installer_XXXX.log.

Tomas

I am also struggling with the installation process. Following is the attached snapshot that I’ve encountered with during the installation process sequenced downside-up. There are 3-4 other errors as well but because I’m a new user so unable to upload more than one. If somebody has found the solution kindly let me know.

image

Hi @shoaib9121,

Could you attach or send me to dgonzalez at bitnami dot com the installation log? It should be found under your temporal folder and named after something like bitrock_installer_XXXX.log..

Also, did you follow the suggestion given by @tomasp?

Regards,

David Gonzalez.

I have the same problem. Unfortunately I was not able to locate the log file. I checked the standard Windows Temp dir.
Could you advise where to find the log?

Hello @stipps

You should be able to locate the bitrock_installer_XXXX.log under your temporal folder. You can reach that folder writing %TEMP% in the File Browser.
As @tomasp mentioned, could you please check the following post from our wiki?
https://wiki.bitnami.com/Native_Installers_Quick_Start_Guide/Antivirus

Best Regards,

Juan Ariza

I found the log files and was finally able to get the WAMP stack to run.
The httpd.conf contained the following at the bottom of the file:

PHPIniDir "C:/Bitnami/wampstack-7.0.11-2/php"
SetEnv OPENSSL_CONF "C:\Bitnami\wampstack-7.0.11-2/apache2/conf/openssl.cnf"
SetEnv PATH "C:\Bitnami\wampstack-7.0.11-2/apache2/bin;${PATH}"
Include "conf/deflate.conf"
Include "C:/Bitnami/wampstack-7.0.11-2/apache2/conf/bitnami/bitnami.conf"

Which I changed to the following:

PHPIniDir "C:/Bitnami/wampstack-7.0.11-2/php"
SetEnv OPENSSL_CONF "C:/Bitnami/wampstack-7.0.11-2/apache2/conf/openssl.cnf"
SetEnv PATH "C:/Bitnami/wampstack-7.0.11-2/apache2/bin"
Include "conf/deflate.conf"
Include "C:/Bitnami/wampstack-7.0.11-2/apache2/conf/bitnami/bitnami.conf"

I havnt tested it thoroughly yet, but at least apache starts and I can see the Bitnamie start-page …

1 Like

Hello @stipps

We are glad to hear that you could solve your issue. Please let us know if you need further assistance.

Best Regards,

Juan Ariza

I have the same problem, while I was installing. I couldn’t find why this happen.
The error message is “unable to install apache as a service with name wamp stack apache”
I stopped Antivirus program and uninstall Skype. Uninstall Bitnami and install again. But the same problem.
I’ve attached bitrock_installer_xxxx.log. Please help. Thinks.

Hi @brighteekim,

I’m sorry to hear that. We would like to review the installer’s log but it was not properly attached to this community forum, can you attach it or include the content of that file in the message?

Thanks

Hi @jota

I am facing the same issue. It gives “child killed: unknown signal” error while installing. Unfortunately I am not able to attach the installer log as I am a new user. Can you please suggest some ways?

Thanks,
Parimal Sagar.

Hi @parimalsagar91,

Could you please let us know more information about your installation?

  • Is it a new one or are you trying to migrate the installation between machines?
  • Which Bitnami’s app are you trying to install?
  • Which Operating System are you using? Which version?

Can you upload the log to Dropbox or Google Drive and share the link with us?

Thanks

Of course, @jota! Thank you for the quick response.

Please find below the details:

Let me know if I can provide more information.

Thanks,
Parimal Sagar.

Hi @parimalsagar91

Yes… I can see the same error on your log file:

Executing C:\Bitnami\wordpress-4.9.8-0/apache2\bin\httpd.exe -k install -n "wordpressApache" -f "C:\Bitnami\WORDPR~1.8-0\apache2\conf\httpd.conf"
Script exit code: unknown signal

Script output:
 
Script stderr:
 child killed: unknown signal

Unable to install Apache as a service with name wordpressApache
Executing cmd /C start /MIN net start wordpressApache

Could you configure the AntiVirus as described on the guide below?
https://docs.bitnami.com/installer/faq/windows-faq/configuration/configure-antivirus-windows

Then, uninstall and install again the WP stack. Let’s see if that fixes the issue to install apache.

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

Yes of course. Thanks, @jariza! I will try and confirm.

Hi @jariza/ @jota,

I have tried setting up the anti-virus as per the above link. After reinstalling also, it doesn’t work. Same error appears again.

Can you please suggest some other ways?

Thanks,
Parimal.

Hi @parimalsagar91

Could you check if there are other services already installed on the system with the same name? Maybe there’s a conflict on that.

You can do it a described below using PowerShell:

https://docs.microsoft.com/en-us/powershell/module/microsoft.powershell.management/get-service?view=powershell-6

Best Regards,

Juan Ariza

i am having the same problem
it say’s there is a syntax error on line 39
ServerRoot “${SRVROOT}”
on httpd.cong

Hi @mohamedshaban30698,

Please create a new topic in this forum instead of reusing this old one. This way the users will find the answers of each case easier and we will keep the forum clean.

Thanks

1 Like