Unable to access Tomcat server via Brow

Keywords: Tomcat - AWS - Technical issue - Connectivity (SSH/FTP)
Description:
So… I’ve created an instance of Tomcat via the Marketplace. Selected the keypair. Followed the instructions for SSH configuration in Putty and… nothing.

I can’t connect via Putty, I can’t connect via Browser and even the server itself doesn’t even respond to pings. The DNS does resolve. The logs look fine, the server has started up and the password is displayed, but otherwise I’ve got nothing.

I’ve selected London as the region and I’ve tried it on EC2.small and EC2.medium and both don’t work.

I did successfully do this several months ago and it all worked as expected.

Hi @ob1,

Did you follow all the steps in this guide?

https://docs.bitnami.com/aws/faq/get-started/connect-ssh/


Please, click on :heart: if you think my answer was helpful

Yep - followed the instructions for Putty, as I did before, but this time I’m getting nothing…

And ‘by nothing’ I get the error that the connection has timed out, from Putty.

As I said, the server isn’t even responding to pings…?

Hi @ob1,

Please note that the ICMP requests are blocked by the default Security Group rules of your instance. You would need to edit those rules by following these instructions in order to be able to obtain a response.

Apart from that, could you please tell us which option did you choose when launching the Bitnami Tomcat image from the Marketplace under the “Security Group Settings” section?

If, as shown in the image above you click the “Create New Based on Seller Settings”, you will get another form to configure the firewall ports that will be open on your server. By default, port 22 is required for SSH access and ports 80 and 443 for HTTP and HTTPS connections. This is how the new form looks. Please note you need to set a name and description before clicking the “save” button

Alternatively, you can try to manually open ports on your current server by using the guide below

https://docs.bitnami.com/aws/faq/administration/use-firewall/

Hope it helps,
Gonzalo

Gah! That’s sounds likely - thanks for the response. I’ll give it a shot and tell you how I got on.

Yep - that works - what a doofus I am! Thanks for the help.

Hi @ob1,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new thread in case you have any other question.

Best regards,
Gonzalo