Unable to access port 9200 or 5601 from outside the virtual machine

Keywords: ELK - Virtual Machines - Technical issue - Secure Connections (SSL/HTTPS)
Description:
Hello,
I’ve installed the ELK stack via the bitnami .ova file. I imported into Virtual Box and all looks good when I boot. I can curl to the localhost:9200 and get a response, but unable to do so from the host OS (Windows). I’ve tried numerous thing including changing the network adapter mode, adding a second adapter, allowing all traffic through Windows firewall, but no success. I also looked through the iptables rules, and actually I didn’t recall seeing anything specific allowing port 9200 and 5601 through, but I could have missed something there.

Any advice? My goal is to just be able to communicate with my local VM of ELK from my Host OS. Thanks!

Hello @rice,

This is our documentation:
https://docs.bitnami.com/virtual-machine/faq/administration/use-firewall/

I hope it helps

Thank you @davidg! Yes that was exactly what I needed. I’ll be adding the rules to open up 9200 and 5601 so I can access from my host machine.

To confirm, this solved my issue.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.