Unable to access Main Site after Add a New Site in Wordpress Multisite

Keywords: WordPress Multisite - Google Cloud Platform - Technical issue - Secure Connections (SSL/HTTPS)
bnsupport ID: 99b64270-e569-5bf8-c462-7001b7e6f4d4
Description:
I’ve added a new site: urbern.com on to the WP Multiste
install the SSL via bncert-tool
added the virtual host config on to /opt/bitnami/apps/wordpress/conf/httpd-vhosts.conf
then update /opt/bitnami/apache2/conf/httpd.conf with
ServerName localhost:80
then restarted Apache

However, when I now visit mgmtcnsltng.com (the Main Site) it redirects me to urbern.com, and when I visit urbern.com, my browser says too many redirects…

99b64270-e569-5bf8-c462-7001b7e6f4d4

:pray::pray::pray:Thank you so much in advance.

as a temporary measure, I’ve pointed urbern.com to a different server (35.189.28.126). I will change it back once this is resolved🙏

Hello @eddy,

Could you confirm if you followed this guide? What scenario are you setting up?

Apart form that, I can see these errors in your apache error_log:

PageSpeed Serf fetch failure rate extremely high

You can try disabling PageSpeed as explained in this article: https://docs.bitnami.com/google/apps/wordpress/administration/use-pagespeed/#disable-pagespeed

Hi David,

Yes, when I created the MU, I followed the guide, I’m on Scenario 3

I’ve tried to reconfigure by following https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/#alternative-approach this guide, I’m following Alternative Approach - Apache Approach B

but mgmtcnsltng.com and all its sub-sites are showing Service Unavailable…:pray:

48a620b6-13e9-d8b5-7206-2c37a0b16f3b

Hi @eddy,

I can see php-fpm and MySQL services are not running:

-----------------------------------
Get the ctlscript status
-----------------------------------
Running: ./ctlscript.sh status
In: /opt/bitnami

Output:

php-fpm not running
apache already running
mysql not running

Could you please try to start them by executing this command?

sudo /opt/bitnami/ctlscript.sh start

Let us know the results after that (new support tool output).

Regards

Hi David,

Thank you so much for pointing this out - silly me.

I’m now able to access the server, as well as have proceeded with a wildcard SSL installation (I’ve fiddled around and eventually got it working)

The remaining problem is that when I enter ‘mgmtcnsltng.com’(main site) on my browser, it shows “NET::ERR_CERT_COMMON_NAME_INVALID”. However, if I enter ‘styd.mgmtcnsltng.com’ (a sub site), the wild card SSL is recognised.

So, my attempt to the challenge is to redirect mgmtcnsltng.com to www.mgmtcnsltng.com, therefore I modified the redirect in Virtual Host, but no avail - this is may due to my limited knowledge on the REWRITE rules, or I miss to configure other conf files?:pray:

ba8e3be0-7bc8-1204-eac1-7845cf69c7c6

Hello @eddy,

This is our documentation:
https://docs.bitnami.com/aws/apps/wordpress/administration/redirect-custom-domains/#redirect-myappexamplecom-to-wwwmyappexamplecom-128

However, I think the problem is that there is a mismatch between how WordPress is configured and how Apache is configured. It seems you configured the application to work using the non-www one:

define( 'DOMAIN_CURRENT_SITE', 'mgmtcnsltng.com' );

Can you change this parameter in the WordPress’ configuration file as below and check if the error is solved?

define( 'DOMAIN_CURRENT_SITE', 'www.mgmtcnsltng.com' );

Regards

Thank you, David, I’ve proceeded with your recommendation. However, it doesn’t resolve to www.mgmtcnsltng.com.

For convenience, I’m using mgmtcnsltng.com as the main site and generated & installed a separate SSL.

Thank you so much again, David.

Hello @eddy,

Do you mind sharing the support output again so we can check the latest changes?

Regards

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.