Theme Options errors due to wp-content folder structure

Keywords: WordPress - AWS - Technical issue - Application configuration

bnsupport ID: 49515ed6-8b39-d1c0-3ff6-e6738ea5f779

bndiagnostic output:

? Resources: Found possible issues

bndiagnostic failure reason: The tool could not find any issue

Description:
Hi, I have been facing issues, specially with theme options or demo import pages. It has happened with 2 WP sites on AWS, When I see console all the js and CSS are throwing 404 errors, bcos of wp-content structure like this :
wp-content/bitnami/wordpress/wp-content/ …

How can I fix this ? Its a big issue, with too less of support on this.

Hi @gsrinivas08,

That’s not the default configuration of the directory structure and I understand you accidentally modified it and that’s why you are getting errors now. Could you please run these commands and post the output here?

sudo ls -la /bitnami/wordpress
sudo ls -la /bitnami/wordpress/wp-content/

Thanks

I haven’t modified anything, this issue is happening since a month… whenever I am using Lightsail to install WP, Had faced other AWS accounts too…

I recently found this post also from some user: Bitnami Installations Using System Packages Breaking Paths, Causing 404 in Plugins

Seems, the same issue I am having. Pls do check and get back on how to fix

due to this alias, It seems many theme settings are breaking


The theme setting page, Browser console URLs are all 404s, that’s breaking the page, making it unusable…

File manager Screenshot in WP

I hope this will help you understand the issue. I haven’t made any changes to WP Files

Hi @gsrinivas08,

The wp-content folder is a symlink to the /bitnami/wordpress/wp-content one. We use that other folder to persist the data in the Bitnami WordPress containers. In this case, the theme may have problems when following the symlinks (you can report this error to the theme developers) but you can also run these commands to remove the symlink and replace the folder with the original one

sudo rm -rf /opt/bitnami/wordpress/wp-content
sudo mv /bitnami/wordpress/wp-content /opt/bitnami/wordpress/wp-content

Is the problem solved now?

Nope, after doing this site ran into critical error.
There has been a critical error on this website. Please check your site admin email inbox for instructions.

It worked on a Fresh WP instance, I created to test.
But on the existing instance, WP went into a critical error. How can I fix it ?

Hi @gsrinivas08,

I do not know what happening in that instance, you should get more info of the error in the Apache’s log file

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-apache/

This is probably related to the plugins you already have in the instance. You can disable them by renaming the plugins folder and checking if you can access the app later

sudo mv /opt/bitnami/wordpress/wp-content/plugins /opt/bitnami/wordpress/wp-content/plugins.back

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.