The requested URL was not found on this server

Keywords: LAMP/MAMP/WAMP - Virtual Machines - Technical issue - Secure Connections (SSL/HTTPS)

bnsupport ID: 4b616511-93d1-0e6a-4ece-97480effde06

bndiagnostic output:

? Apache: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
The Bitnami HTTPS Configuration Tool successfully instal sertificates, but site returns 404 not found message when trying to open even simple readme.html file using HTTPS. At the same time same URL easy opens by HTTP.

Hello @Rednaxel,

It seems you have a LAMP install with WP. However, the tool did not gather info about WP files. How did you installit?

I can see these errors in your Apache logs:

[Mon Sep 20 07:59:47.784360 2021] [proxy_fcgi:error] [pid 15296:tid 140053900678912] [client 45.181.18.11:53448] AH01071: Got error 'PHP message: PHP Warning:  Undefined array key "host" in /opt/bitnami/projects/blog/wp-includes/canonical.php on line 687PHP message: PHP Warning:  Undefined array key "host" in /opt/bitnami/projects/blog/wp-includes/canonical.php\
 on line 696PHP message: PHP Warning:  Undefined array key "host" in /opt/bitnami/projects/blog/wp-includes/canonical.php on line 699PHP message: PHP Warning:  Undefined array key "scheme" in /opt/bitnami/projects/blog/wp-includes/canonical.php on line 720PHP message: PHP Warning:  Undefined array key "host" in /opt/bitnami/projects/blog/wp-includes/canonical.p\
hp on line 687PHP message: PHP Warning:  Undefined array key "host" in /opt/bitnami/projects/blog/wp-includes/canonical.php on line 696PHP message: PHP Warning:  Undefined array key "host" in /opt/bitnami/projects/blog/wp-includes/canonical.php on line 699PHP message: PHP Warning:  Undefined array key "scheme" in /opt/bitnami/projects/blog/wp-includes/canonical\
.php on line 720'

Let me share with you our WP troubleshooting guide:
https://docs.bitnami.com/virtual-machine/how-to/troubleshoot-wordpress-issues/

Regards

Hello David!
I think these errors does not related to this issue. Reasons:

  1. by HTTP site is working fine;
  2. I get 404 error even when opening simple html file
    Do you agree ?

More of that: I suspect errors are the result of incorrect Bitnami HTTPS Configuration Tool operation. I just nothing more than install Wordpress and there was no errors before using Bitnami Tool.
P.S.: It is two virtual hosts configured on the Virtual Machine

Hello @Rednaxel,

It is difficult to guide you since this installation does not follow our recommended approach (e.g. Wordpress should be under /opt/bitnami/wordpress). That’s why the tool did not work as expected.

I can see that you have /opt/bitnami/apache/conf/vhosts/blog-vhost.conf file. However, you don’t have /opt/bitnami/apache/conf/vhosts/blog-https-vhosts.conf file for HTTPS configuration. You can find more information about this at this link.
https://docs.bitnami.com/virtual-machine/infrastructure/lamp/configuration/configure-custom-application/

I hope it helps

It is difficult to guide you since this installation does not follow our recommended approach (e.g. Wordpress should be under /opt/bitnami/wordpress ). That’s why the tool did not work as expected.

I need two independent Wordpress sites – one for www.umd.by and second for blog.umd.by. Can you give me recommendations for the correct solution for this task?

Hello @Rednaxel,

For several WordPress installations we recommend using WordPress Multisite. Find below our documentation explaining different scenarios:

https://docs.bitnami.com/general/apps/wordpress-multisite/configuration/configure-wordpress-multisite/

Regards

I’m sorry, but WP Multisite does not fit my requirements. Actually I need two independent WP Sites.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.