The latest version of nginx is not stable

Keywords: WordPress + NGINX + SSL - Google Cloud Platform - Technical issue - Other
Description:
It doesn’t support pagespeed module, no brotli included as mentioned in the latest release.
PHPMyAdmin blank page issue due to misconfiguration or we’ve to edit the nginx file, remove the
include for all .conf files, and have to add include function for only default server file.

How to add pagespeed and brotli. Even this version not includes lego.
If it included then how to access all these?

Hi @ashoksihmar,

Thanks for using our images. We are in the process of updating our assets to use system packages. We decided not to include PageSpeed for NGINX because they don’t offer any precompiled version for this webserver.

About brotli, we notified the engineering team and they are evaluating to include it in a future release. Regarding phpMyAdmin, you are right and there is an issue with the NGINX configuration. They are looking into it and will release a new revision with the fix.

Thanks for the feedback @ashoksihmar, and sorry for the inconvenience. We have identified the issue with phpMyAdmin and we’re working on releasing a new revision of images with a fix.

To apply the fix on your side, edit the /opt/bitnami/nginx/conf/bitnami/phpmyadmin.conf file and make the following change:

-location /phpmyadmin {
+location ^~ /phpmyadmin {

Afterwards, restart the NGINX server:

$ sudo /opt/bitnami/ctlscript.sh restart nginx

We also expect to include Brotli in this image. We will let us know once it’s released.

Thanks for the lines :slight_smile:

The packed is NGINX WordPress SSL, but lego is not included to generate the SSL certificate.
And I can’t find these too, which are mention in the stack properties.
the package idicates that the software included are
Apache PageSpeed Module (1.13.35-2)
mod_pagespeed_ap24 library (1.13.35-2)
mod_pagespeed library (1.13.35-2)
Apache Portable Runtime (APR) (1.7.0)
Apache utilities (APR) (1.6.1)
Apache (2.4.46)
ModSecurity (3.0.4)
ModSecurity Apache Connector (0.20201020.0)
But I can’t find these, and if, apache pagespeed is there. How to configure?

How to activate Varnish?
The following code is not working, as the find is located here.
https://docs.bitnami.com/bch/apps/wordpress-pro/administration/configure-use-varnish/#enable-varnishtm-126

Keywords: WordPress + NGINX + SSL - Google Cloud Platform - Technical issue - Other
Description:
Hello Bitnami Team, thanks for upgrading the WordPress +NGINX+ SSL.
How I can activate varnish, and brotli module.
Thanks

Hi @ashoksihmar,

Thanks for reporting the list of components. Most of them are related to the Apache webserver, while your computer is using NGINX, so they aren’t included.

Regarding Varnish, I was able to enable and start it on my server by following the steps for “Approach A” in the guide below

https://docs.bitnami.com/google/apps/wordpress-pro/administration/configure-use-varnish/

Notice the guide is almost the same than the one you shared, but specific for Google cloud

This method is not working as already tried. As the location of the file has been changed.

Hi, FYI we just released the new cloud images with Brotli. They are included in all Bitnami cloud images of WordPress with NGINX and SSL cloud images, as of version 5.7.2.


With respect to Varnish, if you find any issues enabling it, please share more info on the specific errors you’re seeing and we’ll try to help you. In your case, we recommend to check this page to apply the proper WordPress configuration for Varnish: https://docs.bitnami.com/google/apps/wordpress-pro/configuration/configure-varnish/

Hi @ashoksihmar,

Can you tell us which file you can’t find? I ran the next four commands and Varnish is running on my server

[ -f /opt/bitnami/scripts/varnish/start.sh.disabled ] && sudo mv /opt/bitnami/scripts/varnish/start.sh.disabled /opt/bitnami/scripts/varnish/start.sh
sudo mv /etc/monit/conf.d/varnish.conf.disabled /etc/monit/conf.d/varnish.conf
sudo gonit reload
sudo /opt/bitnami/ctlscript.sh start varnish
1 Like

I already set up my domains on Bitnami WordPress 5.7.1-3-r05 that is currently available with GCP.
I want to include brotli into this. As it doesn’t contain /opt/bitnami/brotli that is available with the latest version.

Thanks sir. for this help

Hi @ashoksihmar,

As Marcos mentioned in his previous post, you will need to launch a new server for version 5.7.2-4 or newer that will include Brotli. In the current version you are using, it is not possible to add the Brotli module.

You can also migrate your application data to the new instance. We have a guide for this too

https://docs.bitnami.com/google/how-to/migrate-wordpress/

Ok but that is not available with Google, I tried to install with google.bitnami.com but this method create disk size error. I’m choosing 20 GB storage, but image size is of 10 GB.

How much time it will take to live new update on GCP.

Hi @ashoksihmar,

I launched a fresh new instance with a 20 GB disk without issues. Can you try again in a different region? I used US-EAST4-C and it worked

ok. how we can install SSL, as I can’t find lego in the latest version too.

Hi @ashoksihmar,

If the tool is not installed on your server, you can install it and create a new SSL certificate by following the steps described in the next guide

https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/#alternative-approach

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.