The Bitnami Apache WAMP in Win10 does not run when I uncomment Include conf/extra/httpd-ssl.conf in the file httpd

Keywords: General - Virtual Machines - How to - Secure Connections (SSL/HTTPS)

Description:
I Have copied the three SSL credentials provided by the domain’s provider on the directory C:\Bitnami\wampstack-7.2.20-1\apache2\conf

The file httpd has:

LoadModule ssl_module modules/mod_ssl.so

#Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf

On the directory C:\Bitnami\wampstack-7.2.20-1\apache2\conf\extra the file httpd-ssl has:

#General setup for the virtual host
DocumentRoot “C:/Bitnami/wampstack-7.2.20-1/apache2/htdocs”
SSLCertificateFile “C:/Bitnami/wampstack-7.2.20-1/apache2/conf/Myserver.crt”
SSLCertificateKeyFile “C:/Bitnami/wampstack-7.2.20-1/apache2/conf/Myserver.key”
SSLCertificateChainFile “C:/Bitnami/wampstack-7.2.20-1/apache2/conf/Mybundle.crt”

Hi @jcbeeck ,

You do not need to uncomment that line, you just need to replace the server.crt and server.key files in the conf directory and restart Apache for it to start using the new certs.

https://docs.bitnami.com/installer/infrastructure/wamp/administration/enable-https-ssl-apache/

However, you can also configure the SSL certs to use in the C:/Bitnami/wampstack-7.2.20-1/apache2/conf/bitnami/bitnami.conf file

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.