Support tool failed to upload file to server

Type: Bitnami Support Tool

Description:
Support bundle file was successfully created, but the automatic upload to Bitnami servers failed

Hello @pcorrenti,

I sent you a private message here in the forum so you can upload the bundle to your favorite service (Google Drive, Dropbox or similar) and share the link with us in the private message.

Regards

Hi @davidg,

I’ve already sent the file privately.

I have a Bitnami wordpress in AWS, running for about 18 months now, but I’ve recently noticed a few error messages when opening “appearance” --> “customize” in WordPress admin dashboard.

I’ve already tried to change the theme to a default one, and deactivate all the plugins, but the error messages persist, as shown below:

Notice: Trying to get property ‘post_status’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/template.php on line 2187

Notice: Trying to get property ‘post_status’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/template.php on line 2191

Notice: Trying to get property ‘post_status’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/template.php on line 2197

Notice: Trying to get property ‘post_status’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/template.php on line 2201

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/template.php on line 2205

Notice: Trying to get property ‘post_status’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/template.php on line 2209

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/template.php on line 2214

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/template.php on line 2218

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/template.php on line 2223

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/elementor/core/admin/admin.php on line 221

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-post-types.php on line 862

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-post-types.php on line 866

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-post-types.php on line 870

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-post-types.php on line 874

Notice: Trying to get property ‘ID’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-post-types.php on line 878

Notice: Trying to get property ‘post_type’ of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/elementor/includes/template-library/sources/local.php on line 984

After showing those errors, the page uploads and works correctly, but they remain in the background. So far, the site is working correctly in the frontend, and these notices are only showed in the WordPress admin dashboard, specifically in appearance --> customize.

Looking forward to your comments.

Regards,
Pablo.-

Hello @pcorrenti,

I see lots of errors regarding Pagespeed. Pagespeed can cause this issue sometimes. Can you try flushing the cache?

https://docs.bitnami.com/general/infrastructure/lamp/administration/use-pagespeed/#flush-the-pagespeed-cache

If that doesn’t work, can you try disabling it entirely?

https://docs.bitnami.com/general/infrastructure/lamp/administration/use-pagespeed/#disable-pagespeed

Apart from that, the support tool is almost empty. Could you please share with us the following commands’ output?:

df -ih
df -h
cd /opt/bitnami
sudo find . -type f | cut -d "/" -f 2 | sort | uniq -c | sort -n
du -h -d 1

Regards

Hi @davidg,

Well, I’ve tried flushing the cache and also deactivated it, but the errors are still there.

Here the outcome of the commands you requested:

image

image

image

Looking forward to your comments.

Thanks,
Pablo.-

Hello @pcorrenti,

Sorry, I forgot to ask for free command. Could you run it:

sudo su
cd /opt/bitnami
free -m
df -h
du -h . -d 1 | sort -h
ps -e -o pcpu,nice,state,cputime,args --sort -pcpu | awk '{print $1,$2,$3,$4,$5}'

Alternatively, you can stop the services, run the support tool (share a new ID), and start then the services again:

sudo /opt/bitnami/ctlscript.sh stop
sudo /opt/bitnami/bnsupport-tool
sudo /opt/bitnami/ctlscript.sh start

Regards

Hi @davidg,

Thanks for your reply. I’ve followed your advice and stopped the services to run the bn support tool, and now worded correctly. Please find below the code:

70ed3038-74fe-1d8c-52d2-8797cb206b68

Looking forward to your comments.

Regards,
Pablo.-

Hello @pcorrenti,

I can see this warning:

[28-Jul-2021 00:19:40] WARNING: [pool www] server reached max_children setting (5), consider raising it

This error usually indicates PHP script execution is slow due to busy server resources or buggy scripts. Please check the following guide to increase the number of PHP-FPM child processes:

https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/

Also, use the commands below to set the correct permissions for WP:

sudo chown -R bitnami:daemon /opt/bitnami/apps/wordpress/htdocs/
sudo find /opt/bitnami/apps/wordpress/htdocs/ -type d -exec chmod 775 {} \;
sudo find /opt/bitnami/apps/wordpress/htdocs/ -type f -exec chmod 664 {} \;
sudo chmod 640 /opt/bitnami/apps/wordpress/htdocs/wp-config.php

The rest seems to be ok.

I would suggest to take a look at out WP troubleshooting guide:
https://docs.bitnami.com/aws/how-to/troubleshoot-wordpress-issues/

If that does not help, I would suggest you contact the WordPress’ developers to know more about these errors and how to solve them.

Apart from that, the permissions of the WordPress’ folder are not properly set. Can you run these commands to set the right permissions

Regards

Hi @davidg,

Thanks for your reply. I’ve changed the max_children setting to (8) now. However, I kept in the pool.conf file pm=dynamic. Is that correct? or should I change for pm=ondemand.

After the change, I’ve restarted PHP services. I’ve also configured the permissions as suggested, but I actually have done that before. However, the errors are still there.

Thanks,
Pablo.-

Hello @pcorrenti,

Let me clarify it:

  • pm = dynamic: the number of child processes is set dynamically based on the following directives: pm.max_children, pm.start_servers,pm.min_spare_servers, pm.max_spare_servers.

  • pm = ondemand: the processes spawn on-demand (when requested, as opposed to dynamic, where pm.start_servers are started when the service is started.

You can find more info here:
https://tideways.com/profiler/blog/an-introduction-to-php-fpm-tuning

Note that this change should improve your server performance, but it is not the main reason of your issues.

If our WP troubleshooting guide and the permissions commands did not help, I would suggest you contact the WordPress’ developers to know more about these errors and how to solve them.

Regards

Hi @davidg,

Ok, thank you very much for your support.

Regards,
Pablo.-

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.