Sudo not installed on ownCloud 10.6.0.5

  • Which version of the application are you using?:
    10.6.0.5

  • Please choose how you got the application:
    helm repo bitnami/owncloud

  • Have you installed any plugin or modified any configuration file?:
    no

  • Describe here your question/suggestion/issue (expected and actual results):
    expected: sudo command working
    actual:
    bash: sudo: command not found
    /bin/sh: 1: sudo: not found

  • Steps to reproduce the issue (if relevant):

helm install owncloud --set owncloudUsername=admin,owncloudPassword=redacted,mariadb.mariadbRootPassword=redacted,owncloudHost=redacted bitnami/owncloud

kubectl exec -it owncloud-xxxxxxxxxx-xxxxx -- /bin/bash
or
kubectl exec -it owncloud-xxxxxxxxxx-xxxxx -- /bin/sh

Hi @dagl

Thanks for using Bitnami ownCloud!

I see you are using the Bitnami ownCloud helm chart, are running the helm commands in your system? In that case, your system is the one that is lacking the sudo command.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

The problem occurs after getting interactive shell access to a running ownCloud pod, so inside the image.

We provide technical support for our containers & charts in our Github repositories. Our team is actively monitoring them and will be glad to help you there, usually within a business day, and the whole community will benefit from your contribution. Could you please post your question by creating a new issue in the https://github.com/bitnami/charts repo?

https://github.com/bitnami/charts/issues

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.