Status of LAMP services

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: f58902cf-f643-3d87-eda6-dbb44c0dc5b4

bndiagnostic output:

? Apache: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I created a snapshot from a LAMP server, then i created a new server from snapshot , then i ran the following command : sudo /opt/bitnami/ctlscript.sh status

the error is: Cannot find any running daemon to contact. If it is running, make sure you are pointing to the right pid file (/var/run/gonit.pid) .

the issue was solved , when i restated the server ( which was created from snapshots ) the issue was solved.

i tried a solution from the previous case as below from you team :
Hi @c.codin,

Thanks for the info. I hope your new servers are performing properly. Yes, it is possible to disable the current MySQL server in your server. Please follow the next steps to do so:

Stop MySQL
sudo /opt/bitnami/ctlscript.sh stop mysql
Disable the service and reload the gonit configuration
Copy
sudo mv /etc/monit/conf.d/mysql.conf /etc/monit/conf.d/mysql.conf.disabled
sudo gonit reload

but I have the following error :
sudo gonit reload
Cannot find any running daemon to contact. If it is running, make sure you are pointing to
the right pid file (/var/run/gonit.pid)

Note : the issue is on a different server also I tried many times of snapshots.

Hi @baker.khamiseh,

Thanks for using Bitnami. I’m afraid I’m not fully understanding your question, as you mentioned “the issue was solved”. Can you tell us what are you trying to achieve?

hi gongomgra ;

i mean the issue was solved when I restarted the server, I tried creating many servers from the snapshot at different times but I still have the same output, to solve that issue every time I should restart the server.

BR
Baker

Hi @baker.khamiseh,

Thanks for your message. It is weird that restarting the server works but on the first boot of the snapshot gonit is not working. Can you check if you created the snapshot when gonit was not running? Can you launch a new server from the snapshot and run the next commands to try to debug it?

sudo ps aux | grep gonit
sudo ps aux | grep bitnami

Also try to manually start gonit running this command

sudo gonit

You can get more information about gonit in the next link

https://docs.bitnami.com/aws/apps/wordpress-multisite/administration/configure-use-gonit/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.